summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam2018-08-01 21:54:31 +0800
committerAdam2018-08-01 21:54:31 +0800
commit5dd0332d84b75b320a3e44c35548ce7a8b264c04 (patch)
treeb49486e67133538a2141530c04587c739af73ed2 /PKGBUILD
parent3bc7ad722b4fa93f5440ab7ec9baccbecef1fd29 (diff)
downloadaur-5dd0332d84b75b320a3e44c35548ce7a8b264c04.tar.gz
Update to v1.14.1
It's completely fine to update to v1.14.2, only needs to update commit hash, pkgver and dependency. However lib32-gst-plugin-base-libs in extra is still v1.14.1, thus it will not compile. Signed-off-by: Adam <adam900710@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 21 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03c33b1ebf79..90d2c1caf43c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: orumin <dev@orum.in>
+# Maintainer: Adam <adam900710@gmail.com>
_basename=gst-plugins-ugly
pkgname="lib32-$_basename"
-pkgver=1.12.1
+pkgver=1.14.1
pkgrel=1
pkgdesc="GStreamer Multimedia Framework Ugly Plugins (32-bit)"
arch=('x86_64')
license=('LGPL')
url="https://gstreamer.freedesktop.org/"
-depends=('lib32-gst-plugins-base-libs' 'lib32-libdvdread' 'lib32-lame' 'lib32-libmpeg2' 'lib32-a52dec' 'lib32-libmad' 'lib32-libsidplay'
+depends=('lib32-gst-plugins-base-libs=1.14.1' 'lib32-libdvdread' 'lib32-lame' 'lib32-libmpeg2' 'lib32-a52dec' 'lib32-libmad' 'lib32-libsidplay'
'lib32-libcdio' 'lib32-libx264' 'lib32-opencore-amr' 'lib32-mpg123' 'gst-plugins-ugly')
makedepends=('python' 'lib32-libx264' 'autoconf-archive' 'git' 'valgrind-multilib')
-_commit=53e145066bd6302f041880f2450d7549768d1976 # tags/1.12.1^0
+_commit=005effc365d48964271a7a028d62e5e13da976d3 # tags/1.14.2
source=("git+https://anongit.freedesktop.org/git/gstreamer/gst-plugins-ugly#commit=$_commit"
"gst-common::git+https://anongit.freedesktop.org/git/gstreamer/common")
sha256sums=('SKIP'
@@ -38,11 +39,19 @@ build() {
export CXX='g++ -m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib32 \
- --build=i686-pc-linux-gnu --libdir=/usr/lib32 \
- --with-package-name="GStreamer Ugly Plugins (Arch Linux)" \
- --with-package-origin="http://www.archlinux.org/" \
- --disable-static --enable-experimental --disable-gtk-doc
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib32 \
+ --libdir=/usr/lib32 \
+ --build=i686-pc-linux-gnu \
+ --with-package-name="GStreamer Ugly Plugins (Arch Linux)" \
+ --with-package-origin="http://www.archlinux.org/" \
+ --with-x265-libraries="/usr/lib32/x264/libx264-8bit.so:/usr/lib32/x264/libx264-10bit.so" \
+ --enable-experimental \
+ --disable-gtk-doc \
+ --disable-static
# https://bugzilla.gnome.org/show_bug.cgi?id=655517
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
@@ -50,10 +59,10 @@ build() {
make
}
-check() {
- cd $_basename
- make check
-}
+#check() {
+# cd $_basename
+# make check
+#}
package() {
cd $_basename