summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStarterX42022-06-11 21:50:37 +0200
committerStarterX42022-06-11 21:50:37 +0200
commit498eb96000cefc41b2c1334c4acb9e781c4ae593 (patch)
treeabd1a740f3350736ff9da781a83ed7ea0e4a3f0d /PKGBUILD
parentdce148890b87682746418c4871db498a761980de (diff)
downloadaur-lib32-jemalloc.tar.gz
update to 5.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0ecfe77a96a4..1c82e2dcf2c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,28 @@
-# Maintainer: Andrew Sun <adsun701@gmail.com>
+# Maintainer: Dominik Adrian Grzywak <starterx4 at gmail dot com>
+# Contributor: Andrew Sun <adsun701@gmail.com>
pkgname=lib32-jemalloc
_pkgbasename=jemalloc
-pkgver=5.2.1
+pkgver=5.3.0
pkgrel=1
pkgdesc='General-purpose scalable concurrent malloc implementation (32-bit)'
arch=('x86_64')
url='http://jemalloc.net/'
license=('BSD')
-depends=('lib32-gcc-libs' "${_pkgbasename}")
-makedepends=('gcc-multilib')
+depends=('lib32-glibc')
+makedepends=('clang' 'lib32-clang')
+options=('!lto')
+provides=('libjemalloc.so')
+optdepends=("${_pkgbasename}")
source=("https://github.com/jemalloc/jemalloc/releases/download/${pkgver}/${_pkgbasename}-${pkgver}.tar.bz2")
-sha256sums=('34330e5ce276099e2e8950d9335db5a875689a4c6a56751ef3b1d8c537f887f6')
+sha256sums=('2db82d1e7119df3e71b7640219b6dfe84789bc0537983c3b7ac4f7189aecfeaa')
build() {
cd "${srcdir}/${_pkgbasename}-${pkgver}"
- export CC='gcc -m32'
- export CXX='g++ -m32'
+
+ # FS#71745: GCC-built jemalloc causes telegram-desktop to crash a lot. The reason is still not clear.
+ export CC='clang -m32'
+ export CXX='clang++ -m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
export LDFLAGS+=' -m32'