summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsolaraquarion2016-11-03 12:22:27 -0400
committersolaraquarion2016-11-03 12:22:27 -0400
commit0e510e41a07cdafd9eb46e6f38bc3304713f0965 (patch)
tree393449bf969af6324e65eac528f275b03ec225ae /PKGBUILD
downloadaur-lib32-vo-amrwbenc.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc5225663cb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Justin Dray <justin@dray.be>
+# Contributor: David Roheim <david dot roheim at gmail dot com>
+# Contributor: DrZaius <lou[at]fakeoutdoorsman[dot]com>
+pkgname=lib32-vo-amrwbenc
+_pkgname=vo-amrwbenc
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="VisualOn Adaptive Multi Rate Wideband (AMR-WB) encoder"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/opencore-amr/"
+license=('APACHE')
+depends=('glibc')
+options=('!emptydirs' '!libtool')
+source=(https://repo.dray.be/package-files/${_pkgname}-${pkgver}.tar.gz)
+sha256sums=('5652b391e0f0e296417b841b02987d3fd33e6c0af342c69542cbb016a71d9d4e')
+
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ ./configure --prefix=/usr --libdir=/usr/lib32
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -rf $pkgdir/usr/include
+}