summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMoritz Lipp2015-12-10 22:06:44 +0100
committerMoritz Lipp2015-12-10 22:06:44 +0100
commitdf24ea7dcdf47102d7963b87b554defd2f1af21d (patch)
treedc7cd5541af76495561a15855f866fd1b113dabf /PKGBUILD
downloadaur-libaxolotl-c-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32b2aa37694b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Moritz Lipp <mlq@pwmt.org>
+
+_pkgname=libaxolotl-c
+
+pkgname=libaxolotl-c-git
+pkgver=4c18674
+pkgrel=1
+pkgdesc="Axolotl C Library."
+arch=('i686' 'x86_64')
+url="https://github.com/WhisperSystems/libaxolotl-c"
+license=('GPL')
+depends=()
+makedepends=('git' 'cmake')
+checkdepends=('check' 'openssl')
+conflicts=('libaxolotl-c')
+provides=('libaxolotl-c')
+source=("${_pkgname}::git+https://github.com/WhisperSystems/libaxolotl-c")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$_pkgname"
+ mkdir -p build && cd build
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ ..
+# -DBUILD_TESTING=1 \
+ make
+}
+
+# check() {
+# cd "$srcdir/$_pkgname/build"
+# ctest
+# }
+
+package() {
+ cd "$srcdir/$_pkgname/build"
+ make DESTDIR="$pkgdir/" install
+}
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --always | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+# vim:set ts=2 sw=2 et: