summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12023-04-06 05:26:20 +0800
committerChocobo12023-04-06 05:26:20 +0800
commit5f1464363882d8f4fd69ce1f9432531f3d23d10b (patch)
treeaf73d1f2f504eb5bf8fd6b4d95e1861291950d06 /PKGBUILD
parent4fe32c99512c64939f9c0c5e260169016dc9f3e8 (diff)
downloadaur-libcloudstorage-git.tar.gz
upgpkg: libcloudstorage-git 1.2.r386.gff4e9f0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb25f0dcc549..78a022680461 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libcloudstorage-git
-pkgver=1.2.r385.gf7b5d81
-pkgrel=2
+pkgver=1.2.r386.gff4e9f0
+pkgrel=1
pkgdesc="C++ library providing access to files located in various cloud services"
arch=('i686' 'x86_64')
url="https://code.videolan.org/videolan/libcloudstorage"
license=('LGPL')
depends=('boost-libs' 'crypto++' 'curl' 'fuse3' 'jsoncpp' 'libmicrohttpd' 'mega-sdk' 'tinyxml2')
makedepends=('git' 'boost')
-provides=('libcloudstorage')
+provides=("libcloudstorage=$pkgver")
conflicts=('libcloudstorage')
source=("git+https://code.videolan.org/videolan/libcloudstorage.git"
"0001-Fix-compilation-with-newer-crypto.patch")
@@ -21,7 +21,8 @@ prepare() {
cd "libcloudstorage"
patch -Np1 -i "$srcdir/0001-Fix-compilation-with-newer-crypto.patch"
- git submodule update --init
+
+ git submodule update --init --recursive
}
pkgver() {