summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Kudelin2023-09-06 22:00:07 +0300
committerAnton Kudelin2023-09-06 22:00:07 +0300
commit7d11008ce7e4f660ca1cbb4a47f2f8c60b924bd8 (patch)
tree0bfba398912dd0c3f29ebd6dff922543c300e678 /PKGBUILD
parentcdcffa9c8fa7ec640e50374c7571a837c562c1dc (diff)
downloadaur-libcmatrix.tar.gz
fixed downloading and configuration
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 20 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e469c1fabb6a..8a063aa60194 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
-# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
+# Maintainer: Anton Kudelin <kudelin at proton dot me>
pkgname=libcmatrix
pkgver=3.11.0
-pkgrel=7
+pkgrel=8
pkgdesc="A library designed for numerical studies of problems in NMR"
-arch=('x86_64')
-url="https://www.dur.ac.uk/solids.nmr/software/pnmrsim"
-license=('GPL')
-depends=('openmpi')
-makedepends=('root' 'cblas' 'lapacke')
-source=(https://www.dur.ac.uk/paul.hodgkinson/pNMRsim/libcmatrixR3_lite.tar.gz
+arch=(x86_64)
+url="https://community.dur.ac.uk/solids.nmr/software/pnmrsim"
+license=(GPL)
+depends=(openmpi)
+makedepends=(root cblas lapacke)
+source=(${pkgname}R3_lite-$pkgver.tar.gz::https://community.dur.ac.uk/paul.hodgkinson/pNMRsim/libcmatrixR3_lite.tar.gz
$pkgname-3.11.0-gcc5.2.patch
$pkgname-3.11.0-shared.patch
$pkgname-3.2.1-gcc4.7.patch
@@ -43,17 +43,18 @@ prepare() {
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr \
- --includedir=/usr/include/libcmatrix \
- --with-sse \
- --with-atlas \
- --with-minuit \
- --with-mpi \
- CXX=mpic++ \
- CXXFLAGS="$CXXFLAGS -DHAVE_LIBLAPACK" \
- ATLAS_CFLAGS='-I/usr/include' \
- ATLAS_LIBS='-lcblas' \
- LDFLAGS='-L/usr/lib -L/usr/lib/root'
+ ./configure \
+ --prefix=/usr \
+ --includedir=/usr/include/libcmatrix \
+ --with-sse \
+ --with-atlas \
+ --with-minuit \
+ --with-mpi \
+ CXX=mpic++ \
+ CXXFLAGS="$CXXFLAGS -DHAVE_LIBLAPACK -I/usr/include/openblas -I/usr/include/openblas64" \
+ ATLAS_CFLAGS='-I/usr/include' \
+ ATLAS_LIBS='-lcblas' \
+ LDFLAGS='-L/usr/lib -L/usr/lib/root'
make
}