summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2019-01-09 20:11:42 +0200
committerAdrian Perez de Castro2019-01-09 20:11:42 +0200
commite67d9d9c0238ccac3c4af1d5aabe812b1f97db26 (patch)
tree2299a5d1740e57854b7acd953f33c63284ab3512 /PKGBUILD
parent3dc38c9a9fd3e80fb97aca67861338dac680681a (diff)
downloadaur-libdazzle-git.tar.gz
Update to use arch-meson and add git makedepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8dbe8232785..04e80f9ccc64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
-pkgname='libdazzle-git'
pkgdesc='Companion library to GObject and GTK+'
-license=('GPL3')
-pkgver=3.29.4.r65.g5d6fd6c
+pkgname=libdazzle-git
+license=(GPL3)
+pkgver=3.31.1.r40.ga714ac9
pkgrel=1
-provides=('libdazzle')
-conflicts=('libdazzle')
-makedepends=('meson' 'gobject-introspection' 'vala')
-depends=('gtk3')
-arch=('x86_64' 'i686')
+provides=(libdazzle)
+conflicts=(libdazzle)
+makedepends=(meson gobject-introspection vala git)
+depends=(gtk3)
+arch=(x86_64 i686)
url='https://gitlab.gnome.org/GNOME/libdazzle'
source=("${pkgname}::git+${url}.git/")
sha512sums=('SKIP')
@@ -26,10 +26,7 @@ pkgver () {
build () {
cd "${pkgname}"
rm -rf build
- meson --buildtype release \
- --prefix /usr \
- --sysconfdir /etc \
- --localstatedir /var \
+ arch-meson \
-Denable_gtk_doc=true \
-Dwith_introspection=true \
-Dwith_vapi=true \