summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthias Fulz2024-04-10 23:50:41 +0200
committerMatthias Fulz2024-04-10 23:50:41 +0200
commitaeaf41036a973ec05befed294663e2be9c859a6d (patch)
tree6f2bc5696963456d275443ae5e94db4b56216907 /PKGBUILD
downloadaur-libexmdbpp.tar.gz
libexmdbpp for grommunio
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63993eb34f19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Matthias Fulz <mfulz@olznet.de>
+
+pkgname=libexmdbpp
+pkgver=1.11
+pkgrel=1
+pkgdesc='C++ implementation of the exmdb wire protocol'
+groups=('grommunio')
+arch=('x86_64')
+url='https://grommunio.com'
+license=('AGPLv3')
+makedepends=('autoconf' 'cmake' 'gcc' 'pybind11')
+source=("https://github.com/grommunio/${pkgname}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('c4be089165e439d8f9408c5fdba8aca05ea6a861d6be134850a8d339ab8aac0f')
+
+build() {
+ cmake \
+ -B build \
+ -S "${pkgname}-${pkgver}" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=/usr/lib/ \
+ -DCMAKE_BUILD_TYPE=Release
+
+ cmake --build build
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}