summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Runge2019-07-27 00:52:31 +0200
committerDavid Runge2019-07-27 00:52:31 +0200
commitb1839745be39842b20912add64f84dd09f8b686d (patch)
treeb6fcf626c0ca6dc43e384f919736391d7a4fada2 /PKGBUILD
parentefedb1fc68b5d20b2b2321b234902b7eba932a82 (diff)
downloadaur-libffado-svn.tar.gz
PKGBUILD: Moving to python3/qt5 and getting as close to libffado in community as possible.
Removing python2 patch (upstreamed). Adding alsa-lib to optdepends for test-scs. Removing python2 only code from SConstruct, so scons (using python3) can build it.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 28 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a99129296857..59eb0e3d13fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
# Maintainer: David Runge <dave@sleepmap.de>
-# Maintainer: Ray Rashif <schiv@archlinux.org>
+# Contributor: Ray Rashif <schiv@archlinux.org>
# Contributor: galiyosha@gmail.com
# Contributor: Jon Kristian Nilsen <jokr.nilsen@gmail.com>
_name=libffado
pkgname=libffado-svn
-pkgver=r2730
+pkgver=r2776
pkgrel=1
pkgdesc="Driver for FireWire audio devices (svn version)"
arch=('x86_64')
url="http://www.ffado.org/"
license=('GPL')
-depends=('dbus-c++' 'jack' 'libavc1394' 'libconfig' 'libiec61883' 'libxml++' 'python2')
-makedepends=('python2-pyqt4' 'scons')
-optdepends=('python2-pyqt4: ffado-mixer')
+depends=('dbus-c++' 'libavc1394' 'libconfig' 'libiec61883' 'libxml++' 'python-dbus')
+makedepends=('jack' 'python-pyqt5' 'scons' 'subversion')
+optdepends=('alsa-lib: for test-scs'
+ 'python-pyqt5: for ffado-mixer')
conflicts=('libffado')
provides=('ffado' 'libffado')
-source=("${_name}::svn+http://subversion.ffado.org/ffado/trunk/${_name}"
- 'python2.patch'
-)
-sha512sums=('SKIP'
- 'b85e49bff25d47936d5ef0feb452c128eab61013fba1b16e8f1caf9e3d875d5b749daa9db0c5275e154e5ff3c874b254e467981b6b28266db5d1b5efa532b911')
+source=("${_name}::svn+http://subversion.ffado.org/ffado/trunk/${_name}")
+sha512sums=('SKIP')
pkgver() {
cd "${_name}"
@@ -30,30 +28,37 @@ pkgver() {
prepare() {
cd "${_name}"
- patch -Np1 -i "${srcdir}/python2.patch"
+ # fix icon name, so it's coherent with XDG desktop file name
+ sed -e 's/hi64-apps-ffado/ffado-mixer/g' \
+ -i support/xdg/ffado.org-ffadomixer.desktop
+ # removing python2 only code, that breaks, when running scons based on python3
+ sed -e 's/split(b/split(/' \
+ -e 's/strip().decode()/strip()/' \
+ -i SConstruct
}
build() {
cd "${_name}"
scons PREFIX=/usr \
- MANDIR=/usr/share/man \
- UDEVDIR=/usr/lib/udev/rules.d
+ DEBUG=no \
+ CUSTOM_ENV=True \
+ MANDIR='/usr/share/man' \
+ PYTHON_INTERPRETER='/usr/bin/python3' \
+ PYPKGDIR='/usr/lib/python3.7/site-packages' \
+ UDEVDIR='/usr/lib/udev/rules.d'
}
package() {
cd "${_name}"
-
scons DESTDIR="${pkgdir}" WILL_DEAL_WITH_XDG_MYSELF="True" install
-
- install -Dm644 support/xdg/ffado.org-ffadomixer.desktop \
- "${pkgdir}/usr/share/applications/ffadomixer.desktop"
-
- install -Dm644 support/xdg/hi64-apps-ffado.png \
- "${pkgdir}/usr/share/pixmaps/hi64-apps-ffado.png"
-
- install -Dm644 AUTHORS "${pkgdir}/usr/share/doc/${pkgname}/AUTHORS"
- install -Dm644 README "${pkgdir}/usr/share/doc/${pkgname}/README"
+ # XDG
+ install -vDm 644 support/xdg/ffado.org-ffadomixer.desktop \
+ "${pkgdir}/usr/share/applications/ffado-mixer.desktop"
+ install -vDm 644 support/xdg/hi64-apps-ffado.png \
+ "${pkgdir}/usr/share/icons/64x64/apps/ffado-mixer.png"
+ # docs
+ install -vDm 644 {AUTHORS,README} -t "${pkgdir}/usr/share/doc/${pkgname}"
}
# vim:set ts=2 sw=2 et: