summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2024-06-27 00:10:21 -0300
committerDaniel Bermond2024-06-27 00:10:21 -0300
commite4a463debb93960e3ecf0b5d58b23dcfc2a74647 (patch)
tree148f7724c4b21414ac801240e763472905821b03 /PKGBUILD
parent8cbf0421caa505730284f695586473ed7b611890 (diff)
downloadaur-libheif-git.tar.gz
Match latest upstream changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 38 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 488ae14d4aef..12e4eeaba5a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,40 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=libheif-git
-pkgver=1.16.2.r88.g003a55e
+pkgver=1.18.0rc1.r0.g7b6c39c2
pkgrel=1
pkgdesc='HEIF and AVIF file format decoder and encoder (git version)'
arch=('x86_64')
url='https://github.com/strukturag/libheif/'
-license=('LGPL3' 'MIT')
-depends=('aom' 'dav1d' 'libde265' 'libwebp' 'x265')
-makedepends=('git' 'cmake' 'gdk-pixbuf2' 'libjpeg' 'libpng' 'rav1e' 'svt-av1')
-optdepends=('gdk-pixbuf2: for gdk-pixbuf loader'
- 'libjpeg: for heif-convert and heif-enc'
- 'libpng: for heif-convert and heif-enc'
- 'svt-av1: for svt-av1 encoder'
- 'rav1e: for rav1e encoder')
+license=('LGPL-3.0-or-later' 'MIT')
+depends=('aom'
+ 'libde265'
+ 'libjpeg'
+ 'libpng'
+ 'libwebp'
+ 'x265'
+)
+makedepends=('git'
+ 'cmake'
+ 'dav1d'
+ 'ffmpeg'
+ 'gdk-pixbuf2'
+ 'rav1e'
+ 'svt-av1'
+)
+optdepends=('dav1d: dav1d encoder'
+ 'ffmpeg: hardware decode'
+ 'gdk-pixbuf2: for gdk-pixbuf loader'
+ 'rav1e: rav1e encoder'
+ 'svt-av1: svt-av1 encoder'
+)
provides=('libheif')
conflicts=('libheif')
source=('git+https://github.com/strukturag/libheif.git')
sha256sums=('SKIP')
pkgver() {
- git -C libheif describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+ git -C libheif describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//;s/\.rc/rc/'
}
build() {
@@ -29,17 +43,26 @@ build() {
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-DBUILD_TESTING:BOOL='OFF' \
+ -DWITH_DAV1D:BOOL='ON' \
-DWITH_KVAZAAR:BOOL='OFF' \
+ -DWITH_RAV1E:BOOL='ON' \
+ -DWITH_FFMPEG_DECODER:BOOL='ON' \
+ -DWITH_FFMPEG_DECODER_PLUGIN:BOOL='ON' \
+ -DWITH_SvtEnc:BOOL='ON' \
-Wno-dev
cmake --build build
- # create a license file for the executable tools (lincensed under the MIT license)
- # https://github.com/strukturag/libheif/blob/003a55e13274b88dbf4d1162bb3402205038ce93/COPYING#L1-L2
- sed -n '/MIT[[:space:]]License$/,/^[[:space:]]*SOFTWARE\.$/p' libheif/examples/heif_convert.cc > build/LICENSE.tools
- sed -i 's/^[[:space:]]*//' build/LICENSE.tools
+ # create license files for the executable tools (lincensed under the MIT license)
+ # https://github.com/strukturag/libheif/blob/7b6c39c2427f711f15c3d332e6ed6245d180fc43/COPYING#L1-L2
+ local _tool
+ for _tool in dec enc info thumbnailer
+ do
+ sed -n '/MIT[[:space:]]License$/,/^[[:space:]]*SOFTWARE\.$/p' "libheif/examples/heif_${_tool}.cc" > "build/LICENSE-${_tool}-tool"
+ sed -i 's/^[[:space:]]*//' "build/LICENSE-${_tool}-tool"
+ done
}
package() {
DESTDIR="$pkgdir" cmake --install build
- install -D -m644 build/LICENSE.tools -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 build/LICENSE-{dec,enc,info,thumbnailer}-tool -t "${pkgdir}/usr/share/licenses/${pkgname}"
}