summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:32:54 +0200
committerDaniel Nagy2015-06-08 20:32:54 +0200
commit6963f0c8c925add45356307904e1329aecea8dcb (patch)
tree189be587ad59511f6b8fa60ba53f2369bee29238 /PKGBUILD
downloadaur-libinjection-git.tar.gz
import to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..701b8cd4087c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+
+pkgname=libinjection-git
+_gitname=libinjection
+pkgver=v3.6.0.4.g7250af6
+pkgrel=1
+pkgdesc="SQL / SQLI tokenizer parser analyzer."
+url="https://github.com/client9/libinjection"
+arch=( 'i686' 'x86_64' )
+license=( 'BSD' )
+options=( "!strip" )
+depends=( "bash" )
+makedepends=( "rsync" )
+conflicts=( "$_gitname" )
+provides=( "$_gitname" )
+source=( "git+$url" )
+sha1sums=( 'SKIP' )
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ local ver="$(git describe --always)"
+ printf "%s" "${ver//-/.}"
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ mkdir -p $pkgdir/usr/share/
+ rsync --exclude=.git --exclude=.gitignore --exclude=tests -a ./ \
+ "$pkgdir"/usr/share/$_gitname/
+}