summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Grande2025-01-12 10:35:29 -0500
committerVincent Grande2025-01-12 10:35:29 -0500
commit47bec61be28f56fda650a5343e136d26c5f98b69 (patch)
tree7374c2a84437fddd62067fcb52bcc3664b751913 /PKGBUILD
parent0f0fa2aa32849aa62232b5cf15bec94b0bdc8792 (diff)
downloadaur-libinput-git.tar.gz
fix source link and build options
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7cbd16e02e75..d7be60b8e9ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@ optdepends=('gtk4: libinput debug-gui'
'python-yaml: used by various tools')
provides=(libinput)
conflicts=(libinput)
-source=(git://https://gitlab.freedesktop.org/libinput/libinput.git)
+source=(git+https://gitlab.freedesktop.org/libinput/libinput)
sha256sums=('SKIP')
#validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # Peter Hutterer (Who-T) <office@who-t.net>
@@ -28,7 +28,7 @@ pkgver() {
}
build() {
- arch-meson $pkgname-$pkgver build \
+ arch-meson libinput build \
-D udev-dir=/usr/lib/udev \
-D documentation=false
@@ -45,6 +45,6 @@ check() {
package() {
meson install -C build --destdir "$pkgdir"
- install -Dvm644 $pkgname-$pkgver/COPYING \
- "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dvm644 libinput/COPYING \
+ "$pkgdir/usr/share/licenses/libinput/LICENSE"
}