summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2023-04-04 16:44:07 -0500
committerLuis Martinez2023-04-04 16:45:45 -0500
commita32886e8af67dc98bb8c9a690aff59bd5bd501cd (patch)
tree5739c14fc146a982dba147b5f0a09ef976ca7e15 /PKGBUILD
downloadaur-libinsn-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c992c1d89640
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=libinsn-git
+_pkg="${pkgname%-git}"
+pkgver=30.r6.ge795956
+pkgrel=1
+pkgdesc='Instruction decoder/encoder for 64bit ARM'
+arch=(x86_64)
+url='https://github.com/tihmstar/libinsn'
+license=(LGPL2.1)
+depends=(libgeneral gcc-libs)
+makedepends=(clang git)
+provides=("$_pkg.so" "$_pkg")
+conflicts=("$_pkg")
+source=("$_pkg::git+$url")
+sha256sums=(SKIP)
+
+pkgver() {
+ git -C "$_pkg" describe --long --tags | sed 's/-/.r/;s/-/./'
+}
+
+build() {
+ ## Will not compile with gcc
+ cd "$_pkg"
+ export CC=clang
+ export CXX=clang++
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_pkg"
+ make DESTDIR="$pkgdir/" install
+}