summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip Goto2022-09-07 15:03:35 +0200
committerPhilip Goto2022-09-07 15:03:35 +0200
commitf56feb239d57b72a524e65397f0f3021a18fbc22 (patch)
tree3a62ce8f228dd05b36a066f303cedefd584de87a /PKGBUILD
parentac1d491f86a5945cf459d04fc366f756192434c6 (diff)
downloadaur-libipuz-git.tar.gz
Update to 0.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de44292eedd3..f99b4fa16150 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=libipuz-git
-pkgver=r222.d6ab97a
+pkgver=0.2.0.r0.g9e292ca
pkgrel=1
pkgdesc='Library for parsing .ipuz puzzle files'
arch=(x86_64 aarch64)
@@ -17,12 +17,10 @@ b2sums=(SKIP)
pkgver() {
cd "${srcdir}/${pkgname%-git}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- CFLAGS="${CFLAGS} -Wno-error=format-security"
-
arch-meson "${pkgname%-git}" build
meson compile -C build
}