summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlireza |S.N|2024-01-03 13:43:52 +0330
committerAlireza |S.N|2024-01-03 13:43:52 +0330
commitdb32f8a204ebbac0af3c0c85a3311f7c6f0ffe96 (patch)
tree91ae8121d96c1cf2177e1849fea631353832c8f9 /PKGBUILD
parent7f32ebb022d94517e3023e320c31fbfaa455b9c4 (diff)
downloadaur-libkml-git.tar.gz
Fix versioning and update to the latest version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e09bf45d51ae..6feb1961252d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=libkml-git
_pkgname=libkml
-pkgver=1062.878abd1
+pkgver=1.3.0.r130.g878abd1
pkgrel=1
pkgdesc="A KML library written in C++ with bindings to other languages"
arch=('i686' 'x86_64')
@@ -19,12 +19,15 @@ optdepends=('swig: bindings for additional languages'
makedepends=('cmake' 'swig' 'boost' 'patchelf')
provides=('libkml')
conflicts=('libkml')
-source=("libkml::git+https://github.com/libkml/libkml.git")
+source=("${_pkgname}::git+https://github.com/libkml/libkml.git")
sha256sums=('SKIP')
pkgver() {
- cd ${_pkgname}
- printf "%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+ cd "${_pkgname}"
+ ( set -o pipefail
+ git describe --tags --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
prepare() {