summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordanieltetraquark2024-01-23 15:41:41 +0100
committerdanieltetraquark2024-01-23 15:41:41 +0100
commitcb8507d0472532b979fc6a2edcc7968871370e29 (patch)
treed1b646d93cc3db48b000f794e7a19ac95f7424a6 /PKGBUILD
parent817def4880d320eef09160f4ff967cb2778b49e6 (diff)
downloadaur-liblbfgs.tar.gz
change from historic github url, to tagged release file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ff4dedc951b..c9ba6f98462c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,28 @@
-# Maintainer: Tavian Barnes <tavianator@tavianator.com>
+# Maintainer: danieltetraquark
+# Contributor: Tavian Barnes <tavianator@tavianator.com>
# Contributor: ngukho <ngukho at gmail dot com>
pkgname=liblbfgs
pkgver=1.10
-pkgrel=1
+pkgrel=2
pkgdesc="A C port of the implementation of Limited-memory Broyden-Fletcher-Goldfarb-Shanno (L-BFGS) method written by Jorge Nocedal."
arch=('i686' 'x86_64')
url="http://www.chokkan.org/software/liblbfgs/"
+makedepends=('autoconf-archive' 'libtool')
license=('custom:MIT')
-source=("https://github.com/downloads/chokkan/liblbfgs/$pkgname-$pkgver.tar.gz")
-md5sums=('2a46da6c4014d6b1e8a8790a93edffbb') #generate with 'makepkg -g'
+source=("https://github.com/chokkan/liblbfgs/archive/refs/tags/v$pkgver.tar.gz")
+sha512sums=('2b08dc5d4fdd737575f58983fa7b6c143bc12edaca47b7aeadf221afe6e573fa4a53423f323f569aa93c9dbeafb9b80a6d2f755fec6da04e6b7221f0a67816f8')
build() {
cd "$srcdir/$pkgname-$pkgver"
+ # note: Original tar gz contained the generated files for ./configure, but it is only available from webarchive, so we can simply regenerate them.
+ # URL for historical tar gz file https://web.archive.org/web/20140815101758if_/https://cloud.github.com/downloads/chokkan/liblbfgs/liblbfgs-1.10.tar.gz
+ autoupdate
+ libtoolize --force
+ aclocal
+ autoheader
+ automake --force-missing --add-missing
+ autoconf
./configure --prefix=/usr
make
}