summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilken 'Akiko' Gottwalt2015-11-27 08:16:36 +0100
committerWilken 'Akiko' Gottwalt2015-11-27 08:16:36 +0100
commit23bf2b366ddb6bb8d38c785a8d07759d00b1dfde (patch)
treef4ef1aa01f1cf9fc534e216aac7587b1ec2bbff6 /PKGBUILD
downloadaur-libomxil-component-alsa.tar.gz
Initial commit of OpenMAX Bellagio ALSA component build script including
64 bit fix.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3501f9f82686
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id$
+# Maintainer: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+# Contributor: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+
+pkgname=libomxil-component-alsa
+pkgver=0.1
+pkgrel=1
+pkgdesc="An opensource implementation of the OpenMAX Integration Layer API - ALSA component"
+arch=('i686' 'x86_64')
+url="http://omxil.sourceforge.net"
+license=('LGPL')
+depends=('glibc')
+source=("http://downloads.sourceforge.net/project/omxil/components/libomxalsa-${pkgver}.tar.gz")
+md5sums=('39273f12cc916f70b1758244cf8e61c4')
+
+prepare() {
+ cd ${srcdir}/libomxalsa-${pkgver}
+
+ [ -f Makefile ] && make distclean
+ patch -Np0 -i ../../libomxalsa_64bit.patch
+ autoreconf -fiv
+}
+
+build() {
+ cd ${srcdir}/libomxalsa-${pkgver}
+
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd ${srcdir}/libomxalsa-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+}