summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVadim Yanitskiy2024-01-28 02:56:55 +0700
committerVadim Yanitskiy2024-01-28 02:58:35 +0700
commitcd63e6141a5585f558105d2fe4037ad8cb6d57df (patch)
tree1bc57eadf56268bf7227e185ef7262aa79df438b /PKGBUILD
parent7725e94177868f600d9abd57aac9d21718700d2d (diff)
downloadaur-libosmo-abis-git.tar.gz
fix build, update $pkgver, $pkgdesc, $provides
libosmo-abis requires DAHDI by default since commit: commit d4be696bbc20522a0284b6d0aefa872585f6926f Author: Harald Welte <laforge@osmocom.org> Date: Mon Nov 11 17:00:12 2019 +0100 Enable DAHDI support by default; require --disable-dahdi otherwise Let's build with --disable-dahdi, which limits us to Abis-over-IP.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25c1b77c8e64..8ac803a224ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
-# Maintainer: Josef Miegl <josef@miegl.cz>
+# Maintainer: Vadim Yanitskiy <fixeria@osmocom.org>
+# Contributor: Josef Miegl <josef@miegl.cz>
pkgname=libosmo-abis-git
-pkgver=0.6.0.r2.g3a2aa09
+pkgver=1.5.0.r5.gaa3452c
pkgrel=1
-pkgdesc="This is the A-bis interface library as used by OsmoBSC/OsmoNITB"
+pkgdesc="Osmocom library for A-bis interface"
url="https://osmocom.org/projects/libosmo-abis"
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=(GPL)
depends=('libosmocore' 'ortp' 'talloc')
makedepends=('git')
-provides=(${pkgname%-git})
-conflicts=(${pkgname%-git})
-source=("git+https://git.osmocom.org/${pkgname%-git}")
+provides=("libosmoabis.so=${pkgver}"
+ "libosmotrau.so=${pkgver}")
+conflicts=("${pkgname%-git}")
+source=("git+https://gitea.osmocom.org/osmocom/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
@@ -26,7 +28,10 @@ prepare() {
build() {
cd "${pkgname%-git}"
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-dahdi
make
}