summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnthony Wang2021-09-25 17:26:03 -0500
committerAnthony Wang2021-09-25 17:26:03 -0500
commitaa75543537096fd6739201c570b14ddb18494476 (patch)
tree094ab46d37ac358317940597b48e01fd38cad54d /PKGBUILD
parent2be97b65cc83cfb40b43bd666ceb2f45093b1919 (diff)
downloadaur-libretro-yabause-git.tar.gz
Update PKGBUILD to match the one in the community repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c04aeeef3a0..864998512b18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Maintainer: Anthony Wang <ta180m@pm.me>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=libretro-yabause-git
-pkgver=r2953.c55eef97
+pkgver=r3321.12c869191
pkgrel=1
pkgdesc='Sega Saturn core'
arch=('i686' 'x86_64')
url='https://github.com/libretro/yabause'
license=('GPL2')
groups=('libretro-unstable')
-depends=('glibc' 'libretro-core-info')
+depends=('glew' 'glibc' 'libretro-core-info')
makedepends=('git')
provides=('libretro-yabause')
conflicts=('libretro-yabause')
@@ -22,15 +23,11 @@ pkgver() {
}
build() {
- cd libretro-yabause/libretro
-
- make
+ make -C libretro-yabause/yabause/src/libretro
}
package() {
- cd libretro-yabause/libretro
-
- install -Dm 644 yabause_libretro.so -t "${pkgdir}"/usr/lib/libretro/
+ install -Dm 644 libretro-yabause/yabause/src/libretro/yabause_libretro.so -t "${pkgdir}"/usr/lib/libretro/
}
# vim: ts=2 sw=2 et: