summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Gysin2024-03-13 19:25:30 +0200
committerChristoph Gysin2024-03-13 19:25:30 +0200
commitc0e887a2cc262c68f193784c1dded468f5a01383 (patch)
tree7c72326e9eb11197ea73fc6ed00dfe00d26ab298 /PKGBUILD
parente9f14bead82b821dcf50e87bbdde1adce19bd3d0 (diff)
downloadaur-libsoundio-git.tar.gz
Fix source URL, dependencies and add license
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 52231e52dea3..3914af91bd27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,15 @@
_pkgname=libsoundio
pkgname=${_pkgname}-git
-pkgver=1.1.0.14.g9c90c0b
+pkgver=2.0.0.5.g49a1f78
pkgrel=1
pkgdesc='A C99 library providing cross-platform audio input and output'
arch=('i686' 'x86_64')
url='https://www.github.com/andrewrk/libsoundio'
license=('MIT')
-source=('git://github.com/andrewrk/libsoundio')
-options=('!buildflags')
-depends=('jack2')
-makedepends=('cmake')
+source=('git+https://github.com/andrewrk/libsoundio.git')
+depends=('alsa-lib' 'glibc' 'jack')
+makedepends=('git' 'cmake')
provides=('libsoundio')
conflicts=('libsoundio')
md5sums=('SKIP')
@@ -41,4 +40,6 @@ package() {
make \
-C "$_pkgname.build" \
install DESTDIR="$pkgdir"
+
+ install -Dm644 "$srcdir/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}