summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Menelkir2024-05-22 17:22:13 -0300
committerDaniel Menelkir2024-05-22 17:22:13 -0300
commitc2d02a0d2822e8209f65f1325e1f9c9ecd252910 (patch)
tree958389514d249b9242531a807c4cc653de0fa96a /PKGBUILD
parent894b98d9fe4affb99ce860ddf060cafbbdbcc83a (diff)
downloadaur-libspectrum-git.tar.gz
Added: pkgver() function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 65c597dec837..45f9ea923a5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Daniel Menelkir <dmenelkir at gmail dot com>
pkgname=libspectrum-git
-pkgver=1.6.0.1ec4c7
+pkgver=1.5.0.r29.ge85c934
pkgrel=1
+epoch=1
pkgdesc="ZX Spectrum emulator support library."
arch=('i686' 'x86_64')
url="http://fuse-emulator.sourceforge.net/libspectrum.php"
@@ -12,6 +13,11 @@ depends=('libgcrypt' 'glib2' 'audiofile')
source=("libspectrum::git+https://git.code.sf.net/p/fuse-emulator/libspectrum")
md5sums=('SKIP')
+pkgver() {
+ cd "$srcdir"/libspectrum
+ git describe --long --abbrev=7 | sed 's/^libspectrum-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd "$srcdir"/libspectrum
./autogen.sh