summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHolger Rauch2018-01-30 01:06:41 +0100
committerHolger Rauch2018-01-30 01:06:41 +0100
commitb41c3a3f761ce65ca7ca7126d683e392fffd9d15 (patch)
tree4939720d3e40769afcfbba4056fbaabe9b1e1d15 /PKGBUILD
parentaa0f446fdfe0055b54a69e800a84a346b1eeb9f1 (diff)
downloadaur-libstrl.tar.gz
taking over maintainership (marked as orphan); doxygen workaround commented out, as file was not found in path
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 186b8772e91e..eb40bab5aa31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,13 @@
# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Maintainer: Nathan Phillip Brink <binki@gentoo.org>
+# Contributor: Holger Rauch < holger dot rauch at posteo dot de >
pkgname=libstrl
pkgver=0.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="Implementations of certain GNU-only or BSD-only string-related libc functions, such as strlcpy() and getdelim(), for compat purposes"
+# TODO: What's the right URL? (source URL (mirror) still works, though
url="http://ohnopub.net/~ohnobinki/libstrl"
license=('LGPL3')
arch=(x86_64)
@@ -14,8 +16,8 @@ makedepends=(doxygen libtool pkg-config)
options=(!libtool)
validpgpkeys=('184B7CEB69B57FD42BAF9AF9743A52E86BA81050')
source=(ftp://mirror.ohnopub.net/mirror/${pkgname}-${pkgver}.tar.bz2{,.asc})
-md5sums=('d22fcd8107526d802428be6f0e8f0f60'
- 'SKIP')
+sha512sums=('c79b37aef2cf909529e3afabdf472730f9df2eb3605eeb41a74b56f1c9c43a5be1f23c7f383c4b1c2aacb81b9df1d455a3fe9ec1083d5fcabae4c82ef916df92'
+ 'SKIP')
build() {
cd "${srcdir}"/${pkgname}-${pkgver}
@@ -31,8 +33,9 @@ package() {
cd "${srcdir}"/${pkgname}-${pkgver}
# doxygen workaround
- sed -i 's|man0/strl.h.0|man30/strl.h.30|g' Makefile
- install -Dm0644 man/man30/strl.h.30 "$pkgdir"/usr/share/man/man0/strl.h.0
+ # hrauch: really needed? Besides, file is still named man/man0/strl.h.0...
+ #sed -i 's|man0/strl.h.0|man30/strl.h.30|g' Makefile
+ install -Dm0644 man/man0/strl.h.0 "$pkgdir"/usr/share/man/man0/strl.h.0
make DESTDIR="${pkgdir}" install
}