summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122019-10-20 09:50:31 +0200
committerwillemw122019-10-20 09:50:31 +0200
commit95bf804778b7d3775d6ae2092c9db32f116a6b23 (patch)
tree9a9430d9693ef14afdebc3d0a0c81dc04bdaced0 /PKGBUILD
parent502aab9b7af176521e58c6995bc7bf3142ee84ad (diff)
downloadaur-libtremor-svn.tar.gz
Add patch for message "XIPH_PATH_OGG ... must have Ogg installed" build error
Remove patch "Fix for automake 1.13" Change source URL to https Remove arch=i686
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a074bb7bc209..eda756614ff3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@
_pkgname=libtremor
pkgname=$_pkgname-svn
-pkgver=r19483
+pkgver=r19674
pkgrel=1
pkgdesc="Integer-only, fully Ogg Vorbis compliant software decoder library"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.xiph.org/vorbis/"
license=('BSD')
depends=('libogg')
@@ -15,7 +15,7 @@ makedepends=('subversion')
provides=($_pkgname)
conflicts=($_pkgname)
options=('!libtool')
-source=($pkgname::svn+http://svn.xiph.org/trunk/Tremor)
+source=($pkgname::svn+https://svn.xiph.org/trunk/Tremor)
md5sums=('SKIP')
pkgver() {
@@ -26,8 +26,14 @@ pkgver() {
prepare() {
cd $pkgname
+
# Fix for automake 1.13
- sed -i "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" configure.in
+ #sed -i "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" configure.in
+
+ # Patch for error:
+ # ./configure: line 9215: syntax error near unexpected token `,'
+ # ./configure: line 9215: ` XIPH_PATH_OGG(, as_fn_error $? "must have Ogg installed!" "$LINENO" 5)'
+ sed -i "s/\(XIPH_PATH_OGG(, AC_MSG_ERROR(must have Ogg installed!))\)/#\1/" configure.in
}
build() {