summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJelle van der Waa2016-02-04 22:21:06 +0100
committerJelle van der Waa2016-02-04 22:21:06 +0100
commit6b921d547bf0cbd592c63c93c2455d9798662376 (patch)
tree03d73f749cd20dda214ae3b6ec7c4efa5db83136 /PKGBUILD
downloadaur-libvmime-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef49a2fe3444
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=libvmime-git
+pkgver=1
+pkgrel=1
+pkgdesc="A C++ class library for working with MIME messages"
+arch=('x86_64' 'i686')
+url="http://www.vmime.org/"
+license=('GPL')
+depends=('gsasl'
+ 'gnutls')
+makedepends=('cmake')
+source=("git://github.com/kisli/vmime")
+conflicts=('zarafa-libvmime')
+replaces=('zarafa-libvmime')
+md5sums=('SKIP')
+
+prepare() {
+ mkdir build
+}
+
+build() {
+ cd build
+
+ cmake ../vmime \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=/usr/lib/ \
+ -DCMAKE_BUILD_TYPE=Release
+
+ make
+}
+
+package() {
+ cd 'build'
+
+ make DESTDIR="$pkgdir" install
+}