summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2019-08-12 22:42:00 +0300
committerAdrian Perez de Castro2019-08-12 22:42:00 +0300
commit9e0d0c2b0325ce7e248c851e9017ed44b82bbd2a (patch)
tree41a6e8b781fc2e63403ca6db09587667da1a1f66 /PKGBUILD
parent3b0df856c25cd7678f01734fb1db763479912933 (diff)
downloadaur-libwpe.tar.gz
Bump to version 1.2.1
Also, use the list of checksums from the official releases, and add PGP validation for the public key which signs the tarballs.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f5b008067384..c3ae1adace34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgdesc='Base library for the WPE WebKit port'
pkgname=libwpe
-pkgver=1.2.0
+pkgver=1.2.1
pkgrel=0
url=https://github.com/WebPlatformForEmbedded/libwpe
arch=(x86_64 i686 aarch64)
@@ -11,8 +11,11 @@ conflicts=(libwpe-git)
replaces=(wpebackend)
depends=(gcc-libs libxkbcommon)
license=(custom:BSD)
-source=("https://wpewebkit.org/releases/${pkgname}-${pkgver}.tar.xz")
-sha512sums=('b2e08fc3a6992e2a8f6dcfb1116695417549c97ff8125b0fc32546f88a9f52c098c98b72d178ebd4e6970bd94edbda2f2c76930b912da6654233b4cc59bba689')
+source=("https://wpewebkit.org/releases/${pkgname}-${pkgver}.tar.xz"{,.asc})
+md5sums=('9f26865f06ecf933ddbbf067a7be735f' SKIP)
+sha1sums=('d3f6211a2acafe1bd1f41e826c8efae35335fc92' SKIP)
+sha256sums=('00e103c6fa226b0d979c29d14c9e8168c4bec7b0b5108f3705a037cda5609d7d' SKIP)
+validpgpkeys=('5AA3BC334FD7E3369E7C77B291C559DBE4C9123B')
prepare () {
mkdir -p _build
@@ -25,7 +28,7 @@ build () {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
"../${pkgname}-${pkgver}"
- cmake --build .
+ cmake --build . -j$(nproc)
}
package () {