summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor Korobkovsky2017-02-26 00:38:49 +0300
committerVictor Korobkovsky2017-02-26 00:38:49 +0300
commit8d57a1dd42979a61e5c8e8cff91f82f4b8551788 (patch)
tree9ea90c23d2edb68552c0ba87e364bc041156c97e /PKGBUILD
downloadaur-libximc7.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca1957cb95b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=libximc7
+pkgver=2.9.7
+pkgrel=1
+pkgdesc="Library for controlling stepper and other motors.
+It provides a simple C interface for controlling and configuring engine and controller.
+It uses a common virtual serial port driver embedded in all OS."
+arch=('i686' 'x86_64')
+url="https://en.xisupport.com/projects/enxisupport/wiki/Software"
+depends=('glibc>=2.14')
+license=('custom')
+source_i686=("http://download.ximc.ru/libximc7/libximc7-${pkgver}-i386.deb")
+sha256sums_i686=('68eebf7075ce5466a4db4d522d555aa9f832ad44a0322af3c999931df31caff0')
+source_x86_64=("http://download.ximc.ru/libximc7/libximc7-${pkgver}-amd64.deb")
+sha256sums_x86_64=('fb69f4cedfc165e6e6f8101933d74fb5058a10c9ae7751b49ba444b0fe764bbc')
+
+package() {
+ cd "${srcdir}"
+
+ tar -xzC "${pkgdir}" -f data.tar.gz
+
+ cp -r ${pkgdir}/lib ${pkgdir}/usr/
+ rm -r ${pkgdir}/lib
+}