summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRalph Holmes2016-10-08 14:23:21 +0100
committerRalph Holmes2016-10-08 14:23:21 +0100
commit7d89bfe827270a67226f005385d8474d91d56e05 (patch)
treeb3ae26f1982b0742df6c2880becf512178977ffc /PKGBUILD
parent0c52c2a472f98f8ca8ae1d9744117c7dd44f1ae4 (diff)
downloadaur-libz.tar.gz
Use correct version number and improve PKGBUILD.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7189e6fd81de..137914d8e185 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,31 @@
-# Maintainer: Matheus de Alcantara <matheus.de.alcantara@gmail.com>
+# Maintainer: Ralph Holmes <ybden@ybden.com>
+# Contributor: Matheus de Alcantara <matheus.de.alcantara@gmail.com>
-_srcver='2015.12.26'
pkgname=libz
-pkgver=1.2.8
+pkgver=1.2.8.2015.12.26
pkgrel=1
-pkgdesc='An API- and ABI- compatible replacement drop-in replacement for zlib 1.2.8'
+pkgdesc='An ABI-compatible and API-compatible drop-in replacement for zlib'
arch=('i686' 'x86_64')
-url="http://sortix.org/libz/"
+url="http://sortix.org/$pkgname/"
license=('custom')
-depends=('glibc')
-provides=("zlib")
-conflicts=("zlib")
-source=("https://sortix.org/libz/release/libz-${pkgver}.${_srcver}.tar.gz")
+provides=('zlib')
+conflicts=('zlib')
+source=("https://sortix.org/$pkgname/release/$pkgname-$pkgver.tar.gz")
sha256sums=('abcc2831b7a0e891d0875fa852e9b9510b420d843d3d20aad010f65493fe4f7b')
prepare() {
- cd ${srcdir}/libz-${pkgver}.${_srcver}
+ cd $pkgname-$pkgver
+ grep -A24 'Copyright' zlib.h | sed 's/ //' >LICENSE
}
build() {
- cd ${srcdir}/libz-$pkgver.${_srcver}
+ cd $pkgname-$pkgver
./configure --prefix=/usr
make
}
package() {
- cd ${srcdir}/libz-$pkgver.${_srcver}
-
- make install DESTDIR=${pkgdir}
+ cd $pkgname-$pkgver
+ make install DESTDIR=$pkgdir
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}