summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandros Theodotou2024-02-07 18:27:51 +0900
committerAlexandros Theodotou2024-02-07 18:27:51 +0900
commit4866f2711c18c0ed867d4211da48eea04727832a (patch)
tree7f9e6a0284c0322860c93d0aaf8d14d09edc0334 /PKGBUILD
downloadaur-licensedigger-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4236d7191145
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Alexandros Theodotou <alex at zrythm dot org>
+
+_name=licensedigger
+pkgname="${_name}-git"
+pkgver=0.0.1
+pkgrel=1
+pkgdesc='Tools to convert existing license headers to SPDX compliant headers '
+arch=(x86_64)
+url='https://invent.kde.org/sdk/licensedigger'
+license=(GPL3)
+depends=()
+makedepends=(cmake extra-cmake-modules)
+source=("$_name::git+https://github.com/KDE/licensedigger#branch=master")
+sha256sums=('SKIP')
+
+# TODO
+#pkgver() {
+ #cd $_name
+ #git describe --long --tags | sed "s/\([^-]*-g\)/r\1/;s/-/./g;s/^v//"
+#}
+
+prepare() {
+ cd "${_name}"
+ mkdir -vp build
+}
+
+build() {
+ cd "${_name}/build"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "${_name}/build"
+ make DESTDIR="$pkgdir" install
+}