summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrho2016-07-31 13:45:13 +0545
committerrho2016-07-31 13:45:13 +0545
commit14db1b2f25c594952de688cb9c414e3136e3a6ca (patch)
tree8f0187003e928616afea7d9b7e880da4282ca4d6 /PKGBUILD
downloadaur-lights-out-puzzle-git.tar.gz
auto update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dd7fe9dc33a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: rho <rho.rhoit@gmail.com>
+
+pkgname=lights-out-puzzle-git
+pkgver=0.99.r1.g0564620
+pkgrel=1
+pkgdesc="A bash implementation of lights-out puzzle game"
+arch=('any')
+url="https://github.com/rhoit/lights-out"
+license=('MIT')
+depends=('bash' 'sed')
+optdepends=('figlet')
+makedepends=('git')
+source=('git+https://github.com/rhoit/lights-out.git')
+md5sums=('SKIP')
+_gitname="lights-out"
+
+prepare() {
+ cd $_gitname
+ git submodule init
+ git submodule update
+}
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ git describe --tags > .version
+}
+
+package() {
+ cd $_gitname
+ mkdir -p "$pkgdir/usr/local/bin"
+ DESTDIR="$pkgdir" make install
+}