summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKatie Wolfe2018-11-03 13:43:02 -0400
committerKatie Wolfe2018-11-03 13:43:02 -0400
commit3c6146a93a389910493f7ff1eb0ab82df05c99c2 (patch)
treec0f017fd7bbefd3a1f4f8964e6ca465ec4aa78e0 /PKGBUILD
downloadaur-linerider-advanced.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1dfa7735cade
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Katie Wolfe <katie@dnaf.moe>
+
+pkgname=linerider-advanced
+pkgver=1.04
+pkgrel=1
+pkgdesc="An open source spiritual successor to the flash game Line Rider 6.2 "
+arch=("x86_64")
+url="https://github.com/jealouscloud/linerider-advanced"
+license=("GPL3")
+depends=("mono")
+makedepends=("unzip")
+source=("https://github.com/jealouscloud/linerider-advanced/releases/download/v${pkgver}/linerider104.zip"
+ "linerider-advanced-launcher")
+md5sums=('fadba49887d4c2fc7bc6afd8e8a787af'
+ '168c15cb67944b893f4dbdd87cec4c32')
+provides=("linerider-advanced")
+conflicts=("linerider-advanced")
+
+package() {
+ # Wrapper script
+ install -d "$pkgdir/usr/bin"
+ install -m755 "linerider-advanced-launcher" "$pkgdir/usr/bin/${pkgname}"
+
+ # Install binaries and stuff to /opt/
+ cd "$srcdir/linerider"
+ install -d "$pkgdir/opt/${pkgname}"
+ cp -a "." "$pkgdir/opt/${pkgname}"
+ chmod 755 "$pkgdir/opt/${pkgname}/linerider.exe"
+
+}