summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoregnappahz2020-04-19 23:49:19 +0200
committeregnappahz2020-04-19 23:49:19 +0200
commit9f97ce9ecbd5ef64011005d83063cdbe7f0c4f62 (patch)
tree300a00d61e1a3e55f7c0b7d41dee91117bd34654 /PKGBUILD
parent39a52a77b822ce7ddaf2c58565f54b50c0b380b0 (diff)
downloadaur-9f97ce9ecbd5ef64011005d83063cdbe7f0c4f62.tar.gz
Implemented suggested amdgpu patch by bedson
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5cd98ad4832..cd4fb99c2d21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase=linux-amd
_srcname=linux
gitver=v5.6.5
pkgver=5.6.v.5
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
@@ -21,15 +21,19 @@ source=('git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git'
"${pkgbase}.preset"
# patch from our gentoo overlords
5012_enable-cpu-optimizations-for-gcc91.patch
+ # amdgpuhang on reboot patch
+ 'amdgpu_hwhang_reboot.patch'
)
sha256sums=('SKIP'
- #config.x86_64
+ #config.x86_64
'dcf938e044b44db4732576b3e8da9eda1790e1931215c3c63fe0c7151d70d6dc'
- #.preset file
+ #.preset file
'71caf34adf69e9e2567a38cfc951d1c60b13dbe87f58a9acfeb3fe48ffdc9d08'
- #patch gentoo
+ #patch gentoo
'cc739c9c9f7ce08e6bbc161b8232208bbc00820342a32fb1f69bff6326ae1370'
- )
+ #amdgpuhang on reboot patch
+ '62fc91e581c56240220dac84b77684387ae3d5c52afc5904f76a8cfa43e73c05'
+)
_kernelname=${pkgbase#linux}
@@ -53,6 +57,10 @@ prepare() {
# Implement cpu optimisation (MZEN2) patch from our gentoo lords
git apply ../5012_enable-cpu-optimizations-for-gcc91.patch
+
+ # Implement amdgpu_hwhang_reboot.patch
+ git apply ../amdgpu_hwhang_reboot.patch
+
# get kernel version
yes "" | make prepare