summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoregnappahz2020-07-19 17:20:51 +0200
committeregnappahz2020-07-19 17:20:51 +0200
commitc26048685794dfe30c76e19a9522a9c936d8f3cd (patch)
tree6db5173bb74afbc58eaa7d9a2cf5c915d7a86bda /PKGBUILD
parent2a68ab233785566ca86a200abf3d513f3bca2a5e (diff)
downloadaur-c26048685794dfe30c76e19a9522a9c936d8f3cd.tar.gz
Improve patching phase
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c92d6d8a90f..9297663dcbd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -55,8 +55,11 @@ prepare() {
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
- # Implement all packaged patches. Ignore errors.
- git apply ../*.patch || echo "ERROR: something went wrong with a gitpatch. Advancing anyway."
+ # Implement all packaged patches.
+ while read patch; do
+ echo "Applying $patch"
+ git apply $patch || echo "ERROR: something went wrong with $patch. Advancing anyway."
+ done <<< $(ls ../*.patch)
# get kernel version
yes "" | make prepare