summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoregnappahz2021-05-18 08:52:24 +0200
committeregnappahz2021-05-18 08:52:24 +0200
commitc98ef288ef1f8f71dcf6b78d6a4281b4490de252 (patch)
tree988d7796027524d33eaf29dc6020f959bf4ff52f /PKGBUILD
parent238553d4b4f49292a1630f1be0f1ad36462976ab (diff)
downloadaur-c98ef288ef1f8f71dcf6b78d6a4281b4490de252.tar.gz
Implemented znver3/MZEN3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b016a0a2faff..a5abd47cfed4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase=linux-amd
_srcname=linux
gitver=v5.12.4
pkgver=5.12.v.4
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
@@ -19,17 +19,17 @@ source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#ta
# linux package install directives for pacman
'linux.install'
# patch from our gentoo overlords
- '5013_enable-cpu-optimizations-for-gcc10.patch'
+ '5010_enable-cpu-optimizations-universal.patch'
)
sha256sums=('SKIP'
#config.x86_64
- '207945959abec5e1be4e1f88457369aeca08a00a4f2c9f09f2a957fdfedd778d'
+ 'e1abfd4cf8d135fbf8c9f9f0f38fa8b0a6a33f8f915a74eb541d3badbaf8e256'
#.preset file
'60c6ba602443e94a9eba3aeee9d194027d69bffaa428c6d055348ebf03681b5c'
#linux install file
'd590e751ab4cf424b78fd0d57e53d187f07401a68c8b468d17a5f39a337dacf0'
#gentoopatch
- '0384ddcf6be0901c3996fb90885f100657eff584b0f64b0a05c25bd81a37b1bb'
+ '9083b94bf9f547cceeed9fe2f37fb201e42d5b00734a86e4ea528447a59d4b9a'
)
_kernelname=${pkgbase#linux}
@@ -76,13 +76,13 @@ build() {
cd "${_srcname}"
#Force zenv2 architecture optimisation.
- export CFLAGS="-march=znver2 -mtune=znver2 -O2 -pipe -fstack-protector-strong"
+ export CFLAGS="-march=znver3 -mtune=znver2 -O2 -pipe -fstack-protector-strong"
export CXXFLAGS="${CFLAGS}"
make ${MAKEFLAGS} LOCALVERSION= bzImage modules
}
_package() {
- pkgdesc="Linux kernel aimed at the latest AMD Ryzen CPU based hardware"
+ pkgdesc="Linux kernel aimed at the latest AMD Ryzen CPU based hardware (ZNVER3/MZEN3)"
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7' 'lzop')
optdepends=('crda: to set the correct wireless channels of your country')
backup=("etc/mkinitcpio.d/${pkgbase}.preset")