summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEggz2024-01-01 15:33:37 +0100
committerEggz2024-01-01 15:33:37 +0100
commit4dfe9810f149b2f511910492b3ae263131e1b4bc (patch)
tree0009aafb09015008a0d18b478c2fa05186f67296 /PKGBUILD
parent00c9a95167e246195f55a3ebfd553e5b5bf97bd5 (diff)
downloadaur-4dfe9810f149b2f511910492b3ae263131e1b4bc.tar.gz
Updated
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 3 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 450ce14dd29d..b3b5f1cb30c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgbase=linux-amd-znver2
_srcname=linux
-gitver=v6.6.8
+gitver=v6.6.9
patchver=20230105
patchname=more-uarches-for-kernel-5.17+.patch
-pkgver=6.6.v.8
+pkgver=6.6.v.9
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -18,8 +18,6 @@ source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#ta
'config.x86_64'
# standard config files for mkinitcpio ramdisk
"${pkgbase}.preset"
- # linux package install directives for pacman
- 'linux.install'
# patch from our graysky archlinux colleague
"https://raw.githubusercontent.com/graysky2/kernel_compiler_patch/$patchver/$patchname"
# nested KVM svm patch
@@ -27,11 +25,9 @@ source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#ta
)
sha256sums=('SKIP'
#config.x86_64
- 'cf02c70d7988f25ee33df7b9e48afd11dbb0a85cd61b50629d70bb57738dfe07'
+ '6091d4e92e6903ee5805db9cdc8d659612ff4cfb6136ebe6abb5ec7fbb5619c1'
#.preset file
'a7dda487e8277bfdf0dd0a6f578b219ae97de84b00df1822330e808c378df907'
- #linux install file
- 'd590e751ab4cf424b78fd0d57e53d187f07401a68c8b468d17a5f39a337dacf0'
#grayskypatch
'81ad663925a0aa5b5332a69bae7227393664bb81ee2e57a283e7f16e9ff75efe'
#flushbyasid.patch
@@ -53,9 +49,6 @@ prepare() {
exit 2
fi
- # don't run depmod on 'make install'. We'll do this ourselves in packaging
- sed -i '2iexit 0' scripts/depmod.sh
-
# Implement all packaged patches and reverts.
msg2 "Implementing custom kernel patches/reverts"
while read patch; do
@@ -90,7 +83,6 @@ _package() {
depends=('coreutils' 'linux-firmware' 'kmod' 'lzop')
optdepends=('crda: to set the correct wireless channels of your country')
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
- install=linux.install
cd "${_srcname}"
@@ -105,14 +97,6 @@ _package() {
make LOCALVERSION= INSTALL_MOD_PATH="${pkgdir}" modules_install
cp arch/$KARCH/boot/bzImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
- # set correct depmod command for install
- cp -f "${startdir}/${install}" "${startdir}/${install}.pkg"
- true && install=${install}.pkg
- sed \
- -e "s/KERNEL_NAME=.*/KERNEL_NAME=${_kernelname}/" \
- -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/" \
- -i "${startdir}/${install}"
-
# install mkinitcpio preset file for kernel
install -D -m644 "${srcdir}/${pkgbase}.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
sed \
@@ -126,14 +110,6 @@ _package() {
rm -f "${pkgdir}"/lib/modules/${_kernver}/build
# remove the firmware
rm -rf "${pkgdir}/lib/firmware"
- # make room for external modules
- ln -s "../extramodules-${_basekernel}${_kernelname:--ARCH}" "${pkgdir}/lib/modules/${_kernver}/extramodules"
- # add real version for building modules and running depmod from post_install/upgrade
- mkdir -p "${pkgdir}/lib/modules/extramodules-${_basekernel}${_kernelname:--ARCH}"
- echo "${_kernver}" > "${pkgdir}/lib/modules/extramodules-${_basekernel}${_kernelname:--ARCH}/version"
-
- # Now we call depmod...
- depmod -b "${pkgdir}" -F System.map "${_kernver}"
# move module tree /lib -> /usr/lib
mkdir -p "${pkgdir}/usr"