summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2018-11-23 14:52:57 -0500
committergraysky2018-11-23 14:52:57 -0500
commit12c154d5af2cf38e953f0ee5a1fd1dfc5acb3cbb (patch)
treee80c82ed062753f3d560531efc64bc3a081562ee /PKGBUILD
parent86aad8b161dec59d527ead1eaa1788e982321073 (diff)
downloadaur-12c154d5af2cf38e953f0ee5a1fd1dfc5acb3cbb.tar.gz
Update to 4.19.4-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f3591a358107..e284747ac2f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -57,7 +57,9 @@ _NUMAdisable=y
# that you currently have probed in your system VASTLY reducing the number of
# modules built and the build time to do it.
#
-# WARNING - ALL modules must be probed BEFORE you begin making the pkg!
+# WARNING - ALL modules must be probed or loaded via a config file BEFORE you
+# begin making the pkg unless you're running modprobed-db (AUR) and building
+# this with makepkg as the user who is keeping the database.
#
# To keep track of which modules are needed for your specific system/hardware,
# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
@@ -161,16 +163,15 @@ prepare() {
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then
- msg "If you have modprobed-db installed, running it in recall mode now"
- if [ -e /usr/bin/modprobed-db ]; then
- [[ -x /usr/bin/sudo ]] || {
- echo "Cannot call modprobe with sudo. Install sudo and configure it to work with this user."
- exit 1; }
- sudo /usr/bin/modprobed-db recall
+ if [ -f $HOME/.config/modprobed.db ]; then
+ msg "Found a modprobed-db database for Steven Rostedt's make localmodconfig"
+ make LSMOD=$HOME/.config/modprobed.db localmodconfig
+ else
+ msg "Running Steven Rostedt's make localmodconfig now"
+ make localmodconfig
fi
- msg "Running Steven Rostedt's make localmodconfig now"
- make localmodconfig
fi
+
# do not run `make olddefconfig` as it sets default options
yes "" | make config >/dev/null