summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2023-05-23 01:57:01 -0400
committergraysky2023-05-23 01:57:01 -0400
commit2d530c8385fc7529565a34d410eff04f0053a04f (patch)
treee9f6b0253c13929a32b57022d9cc40271409d488 /PKGBUILD
parent5bbcb7a87fc7d037c7d524fe6a5bfd77383ff7eb (diff)
downloadaur-2d530c8385fc7529565a34d410eff04f0053a04f.tar.gz
Update to 6.3.3-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD76
1 files changed, 39 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 82a6c64cb3da..860264662d0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ _clangbuild=
# Optionally select a sub architecture by number or leave blank which will
# require user interaction during the build. Note that the generic (default)
-# option is 36.
+# option is 39.
_subarch=
# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
@@ -37,39 +37,42 @@ _subarch=
# 11. AMD Zen (MZEN) (NEW)
# 12. AMD Zen 2 (MZEN2) (NEW)
# 13. AMD Zen 3 (MZEN3) (NEW)
-# 14. Intel P4 / older Netburst based Xeon (MPSC)
-# 15. Intel Core 2 (MCORE2)
-# 16. Intel Atom (MATOM)
-# 17. Intel Nehalem (MNEHALEM) (NEW)
-# 18. Intel Westmere (MWESTMERE) (NEW)
-# 19. Intel Silvermont (MSILVERMONT) (NEW)
-# 20. Intel Goldmont (MGOLDMONT) (NEW)
-# 21. Intel Goldmont Plus (MGOLDMONTPLUS) (NEW)
-# 22. Intel Sandy Bridge (MSANDYBRIDGE) (NEW)
-# 23. Intel Ivy Bridge (MIVYBRIDGE) (NEW)
-# 24. Intel Haswell (MHASWELL) (NEW)
-# 25. Intel Broadwell (MBROADWELL) (NEW)
-# 26. Intel Skylake (MSKYLAKE) (NEW)
-# 27. Intel Skylake X (MSKYLAKEX) (NEW)
-# 28. Intel Cannon Lake (MCANNONLAKE) (NEW)
-# 29. Intel Ice Lake (MICELAKE) (NEW)
-# 30. Intel Cascade Lake (MCASCADELAKE) (NEW)
-# 31. Intel Cooper Lake (MCOOPERLAKE) (NEW)
-# 32. Intel Tiger Lake (MTIGERLAKE) (NEW)
-# 33. Intel Sapphire Rapids (MSAPPHIRERAPIDS) (NEW)
-# 34. Intel Rocket Lake (MROCKETLAKE) (NEW)
-# 35. Intel Alder Lake (MALDERLAKE) (NEW)
-# 36. Generic-x86-64 (GENERIC_CPU)
-# 37. Generic-x86-64-v2 (GENERIC_CPU2) (NEW)
-# 38. Generic-x86-64-v3 (GENERIC_CPU3) (NEW)
-# 39. Generic-x86-64-v4 (GENERIC_CPU4) (NEW)
-# 40. Intel-Native optimizations autodetected by GCC (MNATIVE_INTEL) (NEW)
-# 41. AMD-Native optimizations autodetected by GCC (MNATIVE_AMD) (NEW)
+# 14. AMD Zen 4 (MZEN4) (NEW)
+# 15. Intel P4 / older Netburst based Xeon (MPSC)
+# 16. Intel Core 2 (MCORE2)
+# 17. Intel Atom (MATOM)
+# 18. Intel Nehalem (MNEHALEM) (NEW)
+# 19. Intel Westmere (MWESTMERE) (NEW)
+# 20. Intel Silvermont (MSILVERMONT) (NEW)
+# 21. Intel Goldmont (MGOLDMONT) (NEW)
+# 22. Intel Goldmont Plus (MGOLDMONTPLUS) (NEW)
+# 23. Intel Sandy Bridge (MSANDYBRIDGE) (NEW)
+# 24. Intel Ivy Bridge (MIVYBRIDGE) (NEW)
+# 25. Intel Haswell (MHASWELL) (NEW)
+# 26. Intel Broadwell (MBROADWELL) (NEW)
+# 27. Intel Skylake (MSKYLAKE) (NEW)
+# 28. Intel Skylake X (MSKYLAKEX) (NEW)
+# 29. Intel Cannon Lake (MCANNONLAKE) (NEW)
+# 30. Intel Ice Lake (MICELAKE) (NEW)
+# 31. Intel Cascade Lake (MCASCADELAKE) (NEW)
+# 32. Intel Cooper Lake (MCOOPERLAKE) (NEW)
+# 33. Intel Tiger Lake (MTIGERLAKE) (NEW)
+# 34. Intel Sapphire Rapids (MSAPPHIRERAPIDS) (NEW)
+# 35. Intel Rocket Lake (MROCKETLAKE) (NEW)
+# 36. Intel Alder Lake (MALDERLAKE) (NEW)
+# 37. Intel Raptor Lake (MRAPTORLAKE) (NEW)
+# 38. Intel Meteor Lake (MMETEORLAKE) (NEW)
+# 39. Generic-x86-64 (GENERIC_CPU)
+# 40. Generic-x86-64-v2 (GENERIC_CPU2) (NEW)
+# 41. Generic-x86-64-v3 (GENERIC_CPU3) (NEW)
+# 42. Generic-x86-64-v4 (GENERIC_CPU4) (NEW)
+# 43. Intel-Native optimizations autodetected by the compiler (MNATIVE_INTEL) (NEW)
+# 44. AMD-Native optimizations autodetected by the compiler (MNATIVE_AMD) (NEW)
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-ck
-pkgver=6.3.1
-pkgrel=2
+pkgver=6.3.3
+pkgrel=1
arch=(x86_64)
url="https://wiki.archlinux.org/index.php/Linux-ck"
license=(GPL2)
@@ -100,19 +103,19 @@ source=(
"more-uarches-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/$_gcc_more_v.tar.gz"
"ck-hrtimer-$_commit.tar.gz::https://github.com/graysky2/linux-patches/archive/$_commit.tar.gz"
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- 0002-netfilter-nf_tables-deactivate-anonymous-set-from-pr.patch
+ 0002-drm-amd-display-Have-Payload-Properly-Created-After-.patch
)
validpgpkeys=(
ABAF11C65A2970B130ABE3C479BE3E4300411886 # Linus Torvalds
647F28654894E3BD457199BE38DBBDC86092693E # Greg Kroah-Hartman
)
-sha256sums=('78620fb4a7d5e0db1d4eb8d5b1c6e207ba5d19564efa63967a59b6daf89b3f2a'
+sha256sums=('8975216a6cee827390586758ed69d19743367098d1fc5dd5694987bb529e44e5'
'SKIP'
- '6b337a9d3cfdc00005589a80b8d36fa500f6a92ed21565a3aceec48d7202a7da'
+ '21b9a9e542f853cdc695648d6ab6219bd2e881a4954277f241e104723c373d42'
'f1d586e111932890ad5e0df15d092fb9b3f87bae4ea17812aae9b0ec98fe2db0'
'f781da5ba492d8912c7d4cddac02f21c1799532182e23374c80c19ff0c617373'
- '9346a69dad1c83417322551a5af677e5134da9097df6fc60897bf9d35c067df0'
- '844c8e4c4b8c6f44a5f0e746c767092cbabf6522d9012d237397ae159ebc3ede')
+ 'c90ccb8accf7fa59f79318b749f0243c96ed9c1e35461f0dae50772f87a467a3'
+ '5e0f9ee19cb3ef6b811e1563690852b03bbc73c35113ab765a53597cf2030883')
_make() {
test -s version
make KERNELRELEASE="$(<version)" "$@"
@@ -124,7 +127,6 @@ prepare() {
msg2 "Setting version..."
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
-#
make defconfig
make -s kernelrelease > version
make mrproper