summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2021-09-15 21:03:40 -0400
committergraysky2021-09-15 21:03:40 -0400
commit6e7d8e28363743756361639e5f0671835b8cab3d (patch)
treef4556f2f224758fbcf6da42b3f9111a56fddc5df /PKGBUILD
parent92475bb0b0563a5f95697b148a6282fa0be1fb13 (diff)
downloadaur-6e7d8e28363743756361639e5f0671835b8cab3d.tar.gz
Update to 5.14.4-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 81780fc9841f..27d3b93b26d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -64,7 +64,7 @@ _subarch=
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-ck
-pkgver=5.14.3
+pkgver=5.14.4
pkgrel=1
arch=(x86_64)
url="https://wiki.archlinux.org/index.php/Linux-ck"
@@ -79,28 +79,26 @@ options=('!strip')
_commit=e2d48df5def86f498766b22e836a9c2f1bcb3809
_xan=linux-5.14.y-xanmod
-_gcc_more_v=20210818
+_gcc_more_v=20210914
source=(
"https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar".{xz,sign}
config # the main kernel config file
"more-uarches-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/$_gcc_more_v.tar.gz"
"xanmod-patches-from-ck-$_commit.tar.gz::https://github.com/xanmod/linux-patches/archive/$_commit.tar.gz"
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- 0002-Bluetooth-Move-shutdown-callback-before-flushing-tx-.patch
- 0003-watchdog-iTCO_wdt-Fix-detection-of-SMI-off-case.patch
+ 0002-watchdog-iTCO_wdt-Fix-detection-of-SMI-off-case.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-b2sums=('c4d2bcffe7149f66e37d05f7c13ebfe59263e7474a6f536317cc092eb9d7e917651059edaf71b26022310c67c1f2f017b2147e53bebcbfcc3f2c92dc6213a721'
+b2sums=('68a6954b5a74c5bad61ac420f444f4755db6f167d2cb0d12bc8a0b793100190a96e116a8aee1ea5832869693735e0c4680e8826c36a0e0802a56e931fb41c51d'
'SKIP'
- 'e7b85b8015414c2405c35f811cc3d201e10fb717e94f4c54c921d4a51dafcd61a2ac61695cf4ad5f51a2dcf5fda0558d99a896ec6478f47e7577c7207a4f7a94'
- '5a191fb995303be264e8721318622bee1d1a3822f805ddf21c1002817ca2e144d6d17e1337f37b32dc3aca1a8754e4354a800c1b4d44417aea0acaf326533b35'
+ 'a0f4869294fe26b51f88171b235377df3ab8ad7f93824933f98e7706057419bb9cf2adf31422c0fc654dd07376e375545bc06bd1148666bb638f6640ec281e7b'
+ 'd1c083f96f645679c5214e05f906b47f17ac6a8b3dd2faeb219e3ceda3a008e3fe47c4a79b0345978cec5c5e28da9b20727970cf5c788d52c3782dc5b36aa211'
'bd20774ee2c9856601af2c89a3af95c6abc812b71253368090e9c252edcce452f416bfeed54ced0886d401b5a9e1cb72c16ea5f04a72d8ded596c0d083f80e42'
- '5ed452cf76c91af71db83c138556480fe06b54b8c342d3428bea565861709aa85884f2ded9b60d4c0b29a982da89b987134d829fa73484d02ebaaf55ede53875'
- '81ca359fe4cf6d1a0c9eba0bb92ca75f71d7887b76b5689467372fe3cf8e57446125f0a6b3d0219efeeed1b31fa749efc75379cc275af0e5501637865e42ba00'
- '5209f8331ea8114df6f8d7a916df5eaa16e30c9fa8ffd72da2bcb56f0d4f81a89aec2143009c8b642002fa4c999595006185ccaecbfbaeceb632f144c3decf04')
+ '7addf1973ad4284c5313da2f78e91f1ec4693c472c1bf892f377dfce051d62ba4d1adf00d70f5f015206f53d55faa589e076a60401defb4e9632ed04d310e2bc'
+ 'c1bfe16e54181905301bbf6b4334e4ea17f9e81f15455e96890610f4447c7cca405e968801c71544f080d8220a4c02e933da3a36c10b56a8a874725ade83a5c3')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
@@ -165,7 +163,7 @@ prepare() {
# https://github.com/graysky2/kernel_gcc_patch
# make sure to apply after olddefconfig to allow the next section
echo "Patching to enable GCC optimization for other uarchs..."
- patch -Np1 -i "$srcdir/kernel_compiler_patch-$_gcc_more_v/more-uarches-for-kernel-5.8+.patch"
+ patch -Np1 -i "$srcdir/kernel_compiler_patch-$_gcc_more_v/more-uarches-for-kernel-5.8-5.14.patch"
if [ -n "$_subarch" ]; then
# user wants a subarch so apply choice defined above interactively via 'yes'