summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2021-06-06 10:00:58 -0400
committergraysky2021-06-06 10:01:00 -0400
commitea761e95a8b813d3ad3ca741b50bc4453c922a74 (patch)
tree8212398c218a9ff23da8ea917b6a5b2e2db83c88 /PKGBUILD
parent0b1f0e32b175ae70c341cc29304067abbda75b63 (diff)
downloadaur-ea761e95a8b813d3ad3ca741b50bc4453c922a74.tar.gz
Update more uarch patch due to upstream rename
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a87b639fd75..1a0f8c92a3a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -78,11 +78,11 @@ makedepends=(
)
options=('!strip')
_ckpatch="patch-5.12-ck${_ckpatchversion}"
-_gcc_more_v=20210412
+_gcc_more_v=20210606
source=(
"https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar".{xz,sign}
config # the main kernel config file
- "more-uarches-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz"
+ "more-uarches-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/$_gcc_more_v.tar.gz"
"http://ck.kolivas.org/patches/5.0/5.12/5.12-ck${_ckpatchversion}/$_ckpatch.xz"
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
)
@@ -93,7 +93,7 @@ validpgpkeys=(
b2sums=('c4ba5b7da3e7af4edb3511b63a21f3d6ca8138f4a5fa77714f49a97f7c06db21daf3df66bb905561d6975b6652bf5b517e995f5e673328b9df3415f37ac01fd0'
'SKIP'
'18d9f071699c9e9bb4c7d340f4d688554b818a4f7fdcefeee24b8b39fc9328737c6967cfd7e884b518e0c87cfb64ac7a10368ac82436d73f96f0881b5c201099'
- '72194a32a06c43809d1272bd675890b6d27c6c54353150a366e8e2c50ad6eca6ee23c5d6281822965a228cfedfa07a60fe135d1b4f539e4a62728d4460cc0b0e'
+ '3f1fff0ed89a618dfa25e041ccc11b8c31de8c7849551ba5289d16268b22f1f36d3eedf99e21d24a325aa7522aa76c1d7be265c1bb8f49e8121d4ba02b77174b'
'c9f729ba1efe6f04e7b2c57d3999bc9675b577596dccb2f227e5b6e444285e1fdd270bf67c0fcf9f5808a4c3a4b1c7a5c13a76f754ad9b9447243ccbaf2ce6a3'
'e1eccb5b6b728e3852ade55dae7a53b8b6bd5f0fb2a330b99e85bfa64abaa430cb714d301ed169df14a1f302a75d952992f0d8fa6ab02fa6716165bdf23b63aa')
@@ -157,7 +157,7 @@ prepare() {
# https://github.com/graysky2/kernel_gcc_patch
# make sure to apply after olddefconfig to allow the next section
echo "Patching to enable GCC optimization for other uarchs..."
- patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/more-uarches-for-kernel-5.8+.patch"
+ patch -Np1 -i "$srcdir/kernel_compiler_patch-$_gcc_more_v/more-uarches-for-kernel-5.8+.patch"
if [ -n "$_subarch" ]; then
# user wants a subarch so apply choice defined above interactively via 'yes'