summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobin Appelman2019-01-05 16:26:54 +0100
committerRobin Appelman2019-01-05 16:26:54 +0100
commit818c0e552fd0c310fa3924ceeb978b7e59dc4d49 (patch)
tree8ac809da2362c3ef66e72a56f13e1df8aacde069 /PKGBUILD
parent08dd9fa353e4ae2cc4f7bf39ebaad10d8e5f5499 (diff)
downloadaur-linux-nopsp.tar.gz
update to 4.20.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68b7b33b7f48..332e8c401c3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,10 @@
-# nopsp change: Robin Appelman <robin@icewind.nl>
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
-pkgbase=linux-nopsp # Build stock -ARCH kernel, without AMD's PSP
+pkgbase=linux-nopsp # Build stock -ARCH kernel
#pkgbase=linux-custom # Build kernel with a different name
-_srcver=4.18.12-arch1
+_srcver=4.20-arch1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
@@ -27,9 +26,9 @@ validpgpkeys=(
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- '7313fbe7546d4bb9a1a4353f68bc909f7a3ff8e660bd72dcd8d26da0487787bd'
+ '460b7e8ce10e3c90d9bd12065f3aa7614a4b301b0086a25a66d906786f74203e'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
- '75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
+ 'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
_kernelname=${pkgbase#linux}
@@ -74,15 +73,17 @@ _package() {
install=linux.install
local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
cd $_srcname
msg2 "Installing boot image..."
- install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
msg2 "Installing modules..."
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
# a place for external modules,