summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjose17112016-02-13 09:36:14 +0100
committerjose17112016-02-13 09:36:14 +0100
commit520305b93ad8153291146c2b699addd01a8a97f4 (patch)
tree133bcae4a9a55727cf4801eebee7fc78951cdfd1 /PKGBUILD
parent64d5689b8de384d92f97aa27fee2af40aaa85c6f (diff)
downloadaur-520305b93ad8153291146c2b699addd01a8a97f4.tar.gz
updated to 4.4.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a3831f22564..a960aeefc7d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
-# Maintainer: Jose Riha <jose1711 gmail com>
-# $Id$
+# Maintainer: Jose Riha
+# $Id: PKGBUILD 258839 2016-02-03 14:33:04Z foutrelis $
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
pkgbase=linux-pae
#pkgbase=linux-pae
_srcname=linux-4.4
-pkgver=4.4
-pkgrel=1
+pkgver=4.4.1
+pkgrel=2
arch=(i686)
url="http://www.kernel.org/"
license=('GPL2')
@@ -15,8 +15,8 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
- #"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
- #"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
+ "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
+ "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
# the main kernel config files
'config'
# standard config files for mkinitcpio ramdisk
@@ -24,16 +24,20 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'change-default-console-loglevel.patch'
'0001-sdhci-revert.patch'
'tpmdd-devel-v3-base-platform-fix-binding-for-drivers-without-probe-callback.patch'
- 'CVE-2016-0728.patch')
+ '0001-4.4-revert-btrfs.patch'
+ '0001-4.4-revert-xfs.patch')
sha256sums=('401d7c8fef594999a460d10c72c5a94e9c2e1022f16795ec51746b0d165418b2'
'SKIP'
- '3f60174e468afd833c57ed5968f80aa7bb60e54f452a6366410be4304dd38deb'
+ 'c0218043e61da3921cd14579ae4a8774a6fdad91667a9fdb851d0a35f62edb48'
+ 'SKIP'
+ '168e599d2326d45bddc749b71578508b452dc864809fc43642927c03902648d5'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
'5313df7cb5b4d005422bd4cd0dae956b2dadba8f3db904275aaf99ac53894375'
'ab57037ecee0a425c612babdff47c831378bca0bff063a1308599989a350226d'
- '03bed5b1c6ef34a917e218a46d38cd1347c5ab5693131996113c6cad275dc4e9')
+ '51586b733e9f178bebe577258b6057b035eded516ffe8bf8bbb26cb0b26c4958'
+ 'ffbfaa192d17bfc7c6293aa9a07efe57f65177051ae3d8033d5e45a7bca2e0ad')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -45,7 +49,7 @@ prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
- #patch -p1 -i "${srcdir}/patch-${pkgver}"
+ patch -p1 -i "${srcdir}/patch-${pkgver}"
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
@@ -59,8 +63,9 @@ prepare() {
# https://bugzilla.kernel.org/show_bug.cgi?id=110751
patch -Np1 -i "${srcdir}/tpmdd-devel-v3-base-platform-fix-binding-for-drivers-without-probe-callback.patch"
- # fixes #47820 CVE-2016-0728.patch
- patch -Np1 -i "${srcdir}/CVE-2016-0728.patch"
+ # #47757 fix broken suspend from btrfs and xfs
+ patch -Np1 -i "${srcdir}/0001-4.4-revert-xfs.patch"
+ patch -Np1 -i "${srcdir}/0001-4.4-revert-btrfs.patch"
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream