summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2018-08-21 12:22:07 +0200
committerPiotr Gorski2018-08-21 12:22:07 +0200
commit104aade33099a20512169b1f077b17eb894e2d0b (patch)
treecebfb5c12221b81f8f9639db3b71fc97d349c5bb /PKGBUILD
parent4981f5a59825af0cce9f2ca9f2cf31392e3534b4 (diff)
downloadaur-104aade33099a20512169b1f077b17eb894e2d0b.tar.gz
Add some useful symlinks
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c724a0646daf..be920fe65c52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -327,6 +327,10 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+ msg2 "Adding symlink..."
+ mkdir -p "$pkgdir/usr/src"
+ ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase-$pkgver"
+
msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}
@@ -344,6 +348,10 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
+ msg2 "Adding symlink..."
+ mkdir -p "$pkgdir/usr/share/doc"
+ ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
+
msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}