summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryehuthi2024-01-13 11:30:25 +0200
committeryehuthi2024-01-13 11:30:25 +0200
commitbf3e2a186a78d65d749bb507ed9e20fba183c94a (patch)
treeee29d49c7b570ae873b302fad0e6b380cd084d3b /PKGBUILD
downloadaur-linuxflip-git.tar.gz
add package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1007d50c9aae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: yehuthi <yehuthith@gmail.com>
+pkgname=linuxflip-git
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Detects and executes commands when the computer switches to and from tablet mode."
+url="https://github.com/yehuthi/linuxflip"
+arch=('i686' 'x86_64')
+makedepends=('git' 'cmake')
+source=("repo::git+$url")
+sha256sums=("SKIP")
+
+pkgver() {
+ git --git-dir="$srcdir/repo/.git" describe --tags --abbrev=0 | cut -c 2-
+}
+
+build() {
+ mkdir "$srcdir/repo/build" && cd $_
+ cmake \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev \
+ ..
+ cmake --build .
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install "$srcdir/repo/build"
+}
+