summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXuanrui Qi2024-04-11 15:17:23 +0900
committerXuanrui Qi2024-04-11 15:17:23 +0900
commitdcea7ffbdc84c88d1de0d1ca78154331e70f447a (patch)
tree39c92b248921c955da65309ad9ca6e2379bb9108 /PKGBUILD
parent6f6c3148ae5efa31c027e0d2aff9c070f8e796ea (diff)
downloadaur-liquidprompt.tar.gz
Version 2.2.0-rc2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 20 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6545841978f..2b72be46b23a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tom van der Lee <t0m.vd.l33@gmail.com>
pkgname=liquidprompt
-pkgver=2.1.2
-pkgrel=2
+pkgver=2.2.0_rc.2
+pkgrel=1
pkgdesc="A useful adaptive prompt for Bash & Zsh"
arch=("any")
url="https://github.com/nojhan/liquidprompt"
@@ -22,12 +22,26 @@ optdepends=("acpi: Battery and temperature status"
"mercurial: Show Mercurial repository status"
"subversion: Show Subversion repository status"
"breezy: Show Bazaar repository status"
- "fossil: Show Fossil repository status")
-source=("https://github.com/nojhan/liquidprompt/archive/v${pkgver}.tar.gz")
-sha256sums=('f752f46595519befd1ad83eaa3605cfc05babd485250a0b46916d8eacabf4f26')
+ "fossil: Show Fossil repository status"
+ "kubectl: Show Kubernetes context"
+ "aws-cli: Show Amazon Web Services profile"
+ "docker: Show Docker status"
+ "podman: Show Podman status"
+ "lxc: Show LXC status"
+ "nodeenv: Show nodeenv virtual environment status"
+ "nvm: Show NVM virtual environment status"
+ "terraform: Show Terraform workspace status"
+ "python-virtualenv: Show Python virtual environment status")
+source=("https://github.com/nojhan/liquidprompt/archive/refs/tags/v${pkgver//_/-}.tar.gz")
+sha256sums=('1f4829d21ba07286808b38ea6b80809ff7c93a6502df1d74db4969ce3ada0939')
+
+build () {
+ cd "${pkgname}-${pkgver//_/-}"
+ ./tools/config-from-doc.sh > liquidpromptrc-dist
+}
package() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver//_/-}"
install -Dm755 liquidprompt "${pkgdir}/usr/bin/liquidprompt"
install -Dm644 liquidpromptrc-dist "${pkgdir}/etc/liquidpromptrc"
install -dm755 "${pkgdir}/usr/share/liquidprompt/themes"