summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorReza Jahanbakhshi2022-10-26 00:14:17 +0200
committerReza Jahanbakhshi2022-10-26 00:14:17 +0200
commitbf28effc50ed485ad90ea4cda50df48869fdc38c (patch)
treed7fbc1c05d20547b62c0af9120173167e57704c9 /PKGBUILD
parentea75f3382927d5df2cd23452e1f6fdf887b35530 (diff)
downloadaur-bf28effc50ed485ad90ea4cda50df48869fdc38c.tar.gz
Added python-testtools to makedepend and removed python-sphinx-automodapi dependency.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a8b0174d45e8..9bc813a12a2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,13 +16,13 @@
pkgname=('llvm-git' 'llvm-libs-git' 'llvm-ocaml-git')
-pkgver=16.0.0_r432910.6b6e9d22684d
+pkgver=16.0.0_r439853.1fe096ef59d1
pkgrel=1
arch=('x86_64')
url="https://llvm.org/"
license=('custom:Apache 2.0 with LLVM Exception')
-makedepends=('git' 'cmake' 'ninja' 'libffi' 'libedit' 'ncurses' 'libxml2' 'python-sphinx'
- 'python-sphinx-automodapi' 'lldb' 'ocaml' 'ocaml-ctypes' 'ocaml-findlib'
+makedepends=('git' 'cmake' 'ninja' 'libffi' 'libedit' 'ncurses' 'libxml2'
+ 'python-setuptools' 'lldb' 'ocaml' 'ocaml-ctypes' 'ocaml-findlib'
'python-sphinx' 'python-recommonmark' 'swig' 'python' 'python-six' 'lua53'
'ocl-icd' 'opencl-headers' 'z3' 'jsoncpp' 'ocaml-stdlib-shims')
checkdepends=("python-psutil")
@@ -106,9 +106,7 @@ check() {
package_llvm-git() {
pkgdesc="LLVM development version. includes clang and many other tools"
depends=("llvm-libs-git=$pkgver-$pkgrel" 'perl')
- optdepends=('python: for scripts'
- 'python-setuptools: for using lit = LLVM Integrated Tester'
- )
+ optdepends=('python: for scripts')
provides=(aur-llvm-git compiler-rt-git clang-git lldb-git lld-git polly-git
llvm compiler-rt clang lldb polly lld )
# A package always provides itself, so there's no need to provide llvm-git