summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-17 22:11:22 +0300
committerDimitris Kiziridis2020-07-17 22:11:22 +0300
commitf1cca778a5909ae2451a8445b06b150be1ef71c3 (patch)
tree1e7a9df2586f796512c318e0ea5f2b727a9d67ed /PKGBUILD
parent17cda9fe8faa059c031b626671a1e583fbb0644b (diff)
downloadaur-localxpose-gui.tar.gz
restructure package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 22d1932d2b75..80dfd923e21c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,6 @@ arch=('x86_64')
url='https://localxpose.io'
license=("custom:${pkgname}")
provides=('localxpose')
-depends=('zlib')
makedepends=('gendesk')
options=('!strip')
noextract=("${pkgname}-${pkgver}.AppImage")
@@ -30,7 +29,10 @@ package() {
--icon "${pkgname}"
install -Dm644 "${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
install -d "${pkgdir}/usr/bin"
- install -Dm755 "${srcdir}/${pkgname}-${pkgver}.AppImage" "${pkgdir}/opt/${pkgname}/${pkgname}.AppImage"
- ln -s /opt/localxpose-gui/${pkgname}.AppImage "${pkgdir}/usr/bin/localxpose-gui"
+ install -d "${pkgdir}/opt"
+ cp -avR squashfs-root/ "${pkgdir}/opt/${pkgname}"
+ ln -s /opt/${pkgname}/AppRun "${pkgdir}/usr/bin/${pkgname}"
+ find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} +
+ find "${pkgdir}/opt/${pkgname}" -type f -exec chmod o-w {} +
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file