summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2021-07-23 12:24:55 +0300
committerAdrian Perez de Castro2021-07-23 12:24:55 +0300
commit25bb7a930d9a0214b6c1f24c3617bb0238df93e6 (patch)
treef3dbd717bc65c02439c742e188cb048f18dda71e /PKGBUILD
parente3cfc359b22c92305843636857d50cdacd863be5 (diff)
downloadaur-lowdown.tar.gz
Bump to version 0.8.5
While at it, add a check() function that runs the regreesion tests.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b045d33b24c4..1abcf2bd859d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
pkgname=lowdown
pkgdesc='Markdown translator producing HTML5 and roff documents in the ms and man formats'
-pkgver=0.8.4
+pkgver=0.8.5
pkgrel=1
license=(custom:BSD)
url=https://kristaps.bsd.lv/lowdown/
@@ -9,7 +9,7 @@ arch=(i686 x86_64)
depends=(libmd)
makedepends=(libdiff)
source=("${url}/snapshots/${pkgname}-${pkgver}.tar.gz")
-sha512sums=('d1d63c96a53692286285a64809317f4ff4b6d2f4499d984cd1284787f3d7ce42ff1ef842bfebd0a2cb4deccfa2bf3d20ff0deb41443b361a314fcde0ee59bd72')
+sha512sums=('5951175bfd7b0508d1a87e9a8156a22da9920025db5689f0d21427accf45e333cd1f9950f3f917868cfc8ecbb189364e88e8f5792936e2bb97daef8fbbcbbc1f')
build () {
cd "${pkgname}-${pkgver}"
@@ -21,6 +21,10 @@ build () {
make
}
+check () {
+ make -C "${pkgname}-${pkgver}" regress
+}
+
package () {
cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install