summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephen Gregoratto2020-01-12 13:52:41 +1100
committerStephen Gregoratto2020-01-12 13:52:41 +1100
commit70c8c70367cc9d64adc63ece9fdb41af7b512e7b (patch)
tree3fec6b5af71bf56e753b074fdc3b5ce9fb92c143 /PKGBUILD
parent48fd21c619b904e054b6c25c7943ab9f516d3b96 (diff)
downloadaur-lsvine.tar.gz
update to 0.2.5, switch builds to use rust
lsvine was rewritten in rust as of 0.2.1. As such, the PKGBUILD has been rewritten to use rust package guidelines.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8aa8318650a3..3a85d4fffecb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,27 @@
# Maintainer: Stephen Gregoratto <dev@sgregoratto.me>
pkgname=lsvine
-pkgver=0.1.2
+pkgver=0.2.5
pkgrel=1
pkgdesc="List contents of directories in a vine-like format"
url=https://github.com/autofitcloud/lsvine
license=('APACHE')
-arch=('any')
-depends=('python-click' 'python-pandas' 'python-tabulate' 'python-termcolor')
-makedepends=('python-setuptools')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+depends=('gcc-libs')
+makedepends=('cargo')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('a7b61292d25c6730308594a5177da8b97793f6e3d433802bb102bd53ee9db962')
+sha512sums=('233be0e9dee138dc42561748a1c3d42640ec27b7d8cb937d7467ef6a268cdbd323e38321c37c5f9a31bd104ae8e665c49801585d719e72a37f3fbb62dfe3e075')
build() {
cd "$pkgname-$pkgver"
- python setup.py build
+ cargo build --release --locked --all-features
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ cargo test --release --locked
}
package() {
cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm755 "target/release/lsvine" "$pkgdir/usr/bin/lsvine"
}