summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2020-08-06 12:30:27 +0300
committerCaleb Maclennan2020-08-06 12:30:27 +0300
commit577b1085f8790705fe6d636e62928a936b0d922a (patch)
tree0a687087457b65ddbeb7d593f11548848da08751 /PKGBUILD
parentd56271911d3bbd204848cdac575f82f6aea6725d (diff)
downloadaur-lua-linenoise.tar.gz
upgpkg: lua-linenoise 0.9-5
Bump default to Lua 5.4 and add Lua 5.3 split package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cdeda0c2421c..eb825bc2a821 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
# Contributor: wenLiangcan <boxeed at gmail dot com>
_rockname=linenoise
-pkgname=("lua-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
+pkgname=("lua-$_rockname" "lua53-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
_pkgname=lua-$_rockname
pkgver=0.9
_rockrel=1
-pkgrel=4
+pkgrel=5
pkgdesc='A binding for the linenoise command line library'
arch=('x86_64' 'i686')
url="https://github.com/hoelzro/$_pkgname"
license=('MIT/X11')
-makedepends=('lua' 'lua52' 'lua51' 'luarocks')
+makedepends=('lua' 'lua53' 'lua52' 'lua51' 'luarocks')
source=("$_rockname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('cc1cdb4047edd056a10dcdeec853dbaf5088e2202941d579e4592584d733f09c')
@@ -23,6 +23,11 @@ _package_helper() {
package_lua-linenoise() {
depends+=('lua')
+ _package_helper 5.4
+}
+
+package_lua53-linenoise() {
+ depends+=('lua53')
_package_helper 5.3
}