summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRob Hoelz2017-03-17 07:44:34 -0500
committerRob Hoelz2017-03-17 07:44:34 -0500
commit7df794d003d5a867115009f7ce8549269d08358c (patch)
tree54120ca1a85f9adb506d9c0741a59c230e7105d5 /PKGBUILD
parent5d436f1c6450d76f90e9458089fc00b5c433bd7e (diff)
downloadaur-lua51-posix.tar.gz
Bump luaposix to 33.4.0
Also build from the release tarball so we don't need to install more dependencies just to build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9623fefc2dea..cd55d8827e4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Contributor: Donald Ephraim Curtis <dcurtis@gmail.com>
pkgname=lua51-posix
-pkgver=31
+pkgver=33.4.0
pkgrel=1
pkgdesc='POSIX library for Lua 5.1'
arch=('x86_64' 'i686')
@@ -16,17 +16,11 @@ license=('GPL' 'LGPL')
depends=('lua51')
makedepends=('lua51' 'git' 'help2man')
options=('!makeflags')
-source=("$pkgname::git://github.com/luaposix/luaposix.git#tag=v$pkgver")
+source=("https://github.com/luaposix/luaposix/archive/release-v$pkgver.tar.gz")
md5sums=('SKIP')
-prepare() {
- cd "$pkgname"
-
- ./bootstrap
-}
-
build() {
- cd "$pkgname"
+ cd "luaposix-release-v$pkgver"
LUA=/usr/bin/lua5.1 \
LUA_INCLUDE=-I/usr/include/lua5.1/ \
@@ -39,11 +33,13 @@ build() {
}
check() {
- make -C "$pkgname" check || true
+ cd "luaposix-release-v$pkgver"
+ make check
}
package() {
- make -C "$pkgname" DESTDIR="$pkgdir" install
+ cd "luaposix-release-v$pkgver"
+ make DESTDIR="$pkgdir" install
}
# vim:set ts=2 sw=2 et: