summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorm00n2020-05-17 09:51:41 +0200
committerm00n2020-05-17 09:51:41 +0200
commit83cd013c50296d488762d5e4a18bfa49d3eaeb84 (patch)
tree3f0b51690e10f6eb629181f482664a0b8c9b0156 /PKGBUILD
downloadaur-lv2-speech-denoiser-git.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..977cebe4c9e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Łukasz Mariański <lmarianski@protonmail.com>
+pkgname=lv2-speech-denoiser-git
+pkgver=04cfba9
+pkgrel=1
+epoch=
+pkgdesc=""
+arch=('x86_64')
+url="https://github.com/lucianodato/speech-denoiser"
+license=('LGPL-3.0')
+groups=()
+depends=()
+makedepends=("glibc" "git" "meson" "lv2")
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+# source=()
+# noextract=()
+# md5sums=()
+validpgpkeys=()
+
+prepare() {
+
+ if [ -d "speech-denoiser" ]; then rm -Rf speech-denoiser; fi
+
+ git clone -n https://github.com/lucianodato/speech-denoiser.git
+ cd speech-denoiser
+
+ git config --local advice.detachedHead false
+ git checkout $pkgver
+
+ head -n -1 install.sh > install_new.sh
+}
+
+build() {
+ cd speech-denoiser
+ # chmod +x install.sh && ./install.sh
+ chmod +x install_new.sh && ./install_new.sh
+}
+
+# check() {
+# cd "$pkgname-$pkgver"
+# make -k check
+# }
+
+package() {
+ cd speech-denoiser/build
+
+ # make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir/" ninja install
+}